Upgrade back to previous OS

OK, I wish I’d spent 30 seconds in this forum before allowing WD to ruin one of my PR4100s. It’s VERY clear no one at WD actually uses these devices for their own use so they don’t care what they break, screw up, or otherwise ruin. As such, is there any way, supported or otherwise, to upgrade my PR4100 back to the previous OS?

The other gotcha here is now anyone who made the mistake of putting their NAS on OS5 now relies on WD maintaining their systems indefinitely. I have 15+ year old equipment that works just fine where the vendor is either no longer in business, was sold off and broken up, or otherwise has disabled/discontinued much of their product lines over the years. Where are the guarantees that WD will never disable our logins, never sell this division, never decide it’s not worth their time or $ to maintain, where is this? It’s no where. This is a god awful system people and if this is how all new WD NASs come I will never buy another and will make sure ALL my clients who have them or may need them will never buy one. Ever. Period.

7 Likes

I am completely with you.
This upgrade has screwed my ability to do work for 5 days straight now.

3 Likes

i’m ok with you, ! i’ll going to synolgy quickly, my mycloud ex2 ultra is under waranty again, i’ll send a request to be refurbeshed and i’m going to buy a synology ! wd> never !

ubaOrNotTuba :handshake: I will never buy any NAS solution from WD with mandatory authentication through their corporate servers. They killself their soho network storage segment. This is madness from WD corporation management.

My NASes stay in isolated network, and suppose from now WD solution not acceptable for me and my company. I’m afraid that in the near future I will have to move to a synology or something similar storage solutions.

1 Like

OS5 has ruined my EX4100 & PR4100. I have do do daily reboots. I delete files & later they are back again listed in the file list. I can only access the dashboards from 1 out of 4 computers. I cannot access the recycle bin on either NAS. I will be ordering a Synolgy case tomorrow. Then I will move the drives from the WD junk & moving them to the Synolgy case & starting over.

1 Like

since updating i have had a dead drive absolutely useless
and as for customer support well there is none

I upgraded to OS 5 without performing due diligence and have learned another valuable lesson.
Days indexing and creates system lockups and the network profile of the WD MyCloud Mirror says “No internet access”

I have tried to reinstall OS 3 but it fails as there is no internet.
So basically stick in a rut.

Internet was working in OS 3 as it downloaded OS 5.

Any thoughts on how to get the internet access back so I can downgrade the firmware where everything was working.

I hope someone from WD reads this and posts a tool to roll back to OS3. Bad things found so far:

  1. OS5 forces you to use mycloud account to access your own content within your own LAN when using mobile device. I bought multiple expensive WD NAS devices so I didn’t have to put my data (or my credentials) into “the cloud” and give potential access to third-parties like WD!!!
  2. Remote backups from OS3 to OS5 are impossible and there’s no way I’m going to “upgrade” a second 1000 USD NAS to this downgraded OS. (And yes I have “installed” all the backup “apps” in OS5 that used to be part of OS3… and set up port forwarding but still not able to access destination folder on OS5 device to create backup from OS3 device without getting a login error. And I’m not installing OS5 on the source NAS if it means I have to enable access to mycloud account per point number 1 above).
  3. Mobile app for iOS is useless. Setting aside point number 1 above, it is impossible to even move content between shares on the same NAS. It is impossible to download content for offline viewing on the device. The UI is awful.

PLEASE ENABLE A ROLLBACK. OR FIX THE ISSUES IN OS5 INCLUDING PRIVACY ISSUES WHEN USING NAS WITHIN YOUR OWN LAN… IT SHOULD NOT REQUIRE GIVING WD’S SERVERS ACCESS TO YOUR FILES.

So, there IS a way to roll back. WD lied to us, who’d have thought? :smiley:
Check here. It is for EX line, but for PR should be more or less same:

1 Like

I don’t have the PR line. However, I have actually upgraded to downgrade a few times. Once without the drives installed, once with the drives installed. It does see the lack of drives, new drives, and even the roaming drives from the OS 5. Main thing to note here is the location of the root filesystem on the internal flash drive. From there, hack that volume, nanderase might even would work on just this volume as we are pretty much wanting to do a rm -rf / without killing the boot sector. This gets us into safe mode, and that gets us back to the old OS.

Adding to this thread. My firmware just updated, and yep, it won’t even read the drives anymore. Doesn’t make any sense.