Updating taking forever

Unable to access my cloud home duo for a couple of weeks keeps saying it’s upgrading I have all my business and personal information in there why is this taking so long

1 Like

Gentleman, very sad to hear that your equipment also failed similar to mine. For me, It happened two weeks before. Many follow-ups were made with the WD service team. Finally, they announced that my Hard disk (both) failed. I believe the software made our hard disk fail. Anyways get ready for data recovery. Then, go for a better-branded cloud system.

Hi Raj,
I am also in same situation, have you received any steps to recover the data?

No sir. WD is not helping. They diverted me to third parties.

Hi, I’m new here so hi to all,
It seems a general issue with the “upgrade”…or at least it’s what I think… either that or the so-called upgrade is a total mess up…
And why isn’t Western Digital, looking into this?
What is happening, i want my data back…
its not expected for a so-called home cloud solution, to fail like this…
I need help… at least to downgrade to a previous version, that works…
When i bought this i thought this would be relieable…
Or at least to endure more than the HDD from my computer.

Please somenone help. No third parties bull… fix what u broke… its simple, rollback , or at least help the users to rollback.

This happened to me too :cry: Was updating for over a week, and still nothing. Tried connecting the drives to my computer using a hub, and looks like they’re fried. Thanks a lot WD, all my data is gone.

Any solution for this?

Hi everybody
i have exactly the same problem. Updating for more than 1 week! This is a mess!!! Thank you WD!!!

i buyed the Recovery Explorer Professional Software and i was able to copy all my data to another Harddisk. Now i have a Synology NAS. Ha, this is other stuff, guys!
Bye Bye Western Digital

Has anyone with this issue successfully completed the upgrade process? And if so how long did it finally take?

Noticed My Cloud Duo was rather active more recently and was generally running slower with Network Connectivity using both Local and and KDDFS mapped Drive I put this down to home network traffic (week long home working with 2 additional devices running on 2 different VPNS) when trying to watch a video using plex had to drop video rate down to 320p and even then audio/video was out of sync normally i would reboot via mobile app but Mobile App was stuck at Rebooting from 6 days ago to which I was at the point of Turn it off and on again - Rebooted twice including full home Intranet/internet and was stuck in a blinking loop

Left for about 20 mins and no progress tried Ping to device and was receiving a ping but local NTFS drive was Disconnects and My KDDFS drive was offline checked support pages not that they were very helpful and was able to download the Logs via browser confirm Device was online for the logs to be downloaded

Logged into My Pleax media centre and no media files were visable but Plex was showing CPU/Memory and usage but Mobile/Web and Desktop all still saying device offline

After about an hour Plex and Local NTFS drive restored and able to watch via Plex again but still out of sync and wont support anything over 320P - done a network perfmance test and Internet/Intranet results was current supported speed at the time was 720p but now wont sync at 720P

WD really need to look into a way for to access the drive locally (KDDFS partition) when loss of Network or drive wont go online but for me took about an hour 3 reboots a complete home network reboot alternative ETH and directly connect to ISP Router and no idea that there was an update being deployed to the device Hopefully I have not lost any Data

Anyone figure this out yet ?

i have a raid setup 2x 12 TB, meaning only 6 TB of usable storage.

Now i have a paper brick from WD… a really expensive one… so… don’t know what to do with it. I need to recover this data, family fotos, movies… documents etc…

And this is just… a piece of …
I will go unraid with the nas solution, since this company product actually ■■■■… i just give my review of this… mess of a device over to my friends and family, and just review it has a piece of garbage with no support…