Updating Folder Thumbnails?


#1

I have recently purchased the WD TV Live Hub, and so far I am very happy. I have solved many problems that I have run in to in the last few days. But one problem I can’t seem to resolve. I created three folders “Movies”, “Documentaries”, and “TV Shows”. Originally Movies and Documentaries and movie.avi and movie.jpg files directly in those directories, so the thumbnails for the folders were one of the movies. I then found a jpg  that I want to use as the thumbnail for those folders. So I placed into each folder an named it folder.jpg, but it is still showing the thumbnail for one of the movies.

I tried turning off the WDTV and deleting the .wd_tv/thumbs folder but when I power the unit back on the thumbnail is the same movie thumbnail taht it was before. I also tried removing all files from the folder expect the fodler.jpg and one movie.avi and movie.jpg (it was a movie other then the one that was producing the thumbnail) and it still showed the same thumbnail even though the movie was no longer in the folder. I renamed the folders to MoviesX and DocumentariesX and this work! But when I named the files back it returned it to the old thumbnail of the movie (this movie has still not been placed back in the folder yet).

Also, the TV Show folder I created had all of the videos stored in subfolders so a thumbnail was never generated until I placed the folder.jpg into it, so this one is not giving me any issues.

Any suggestions on how I can keep the original  folder names and get the thumbnails to pull from folder.jpg?


#2

There’s only one way that I’ve that works when nothing else does.  That’s to reflash the firmware.

Download which ever version of firmware you are currently using, then unzip it.  It will unzip 3 files, open the “wdtvlivehub.ver” file and change version number to something higher (this will not actually change the version number that is flashed), then save the file.

Copy the 3 files to a FAT 32 formated thumbdrive, then place the thumbdrive in the HUB’s usb port.   When prompted, select to update.  Once it is finished updating, you should see the new folder icons.


#3

When you say turning it off, did you un plug it or just power it off?  try un plugging it first before reflashing it. might just work.


#4

Thanks! Unplugging it did the trick. Any chance that you know why this worked? Does the WDTV rebuild icons after a complete power loss?


#5

Here’s what works for me … not necessary to unplug, restarting from settings menu has worked everytime so far following these steps (copied from another post I put in a different thread):

Just thought I add my two cents since I have been changing thumbnails a lot.  I make them on the computer, and add them over the network share.  The only efficient and dependable way I have found to get the Hub to recognize the new thumbnails and “forget” the old ones is to do it like this:

After I’ve added the thumbnails (e.g. folder.jpg, or thumbnails named identically to videos) to the Hub using the computer, accessing the Hub as network share, then

  1. Turn off the WD using power off on the remote.

 (you don’t need to unplug or do a hard shut down, in fact this won’t work if you do because you need to access the WD as a network share)

  1. From the computer find “thumb” in directory from the .wd_tv directory in the root HUB directory. Then, delete the whole thumb directory, or navigate more surgically to find the directory you changed or even the actual thumb files. The WD regenerates them rapidly, so it’s not a hassle for me with several hundred thumbs to delete a whole directory. 

  2. Restart the WD using power on from the remote,

  3. Then immediately do a “device restart” from within the menu.  (Home --> Setup --> System --> Device Restart).  This is more like a reboot than just powering off/on with the remote. 

This seems like a lot but it’s been sure-fire for me after a lot of experimentation, with turning the unit on and off, rebuilding the library, moving directories around, looking for files in different views on the Hub, etc. It’s a lot easier than trying “easier” things over and over and/orwaiting for the HUB to get around to finding changes.

Careful though in deleting anything from the Hub, there’s no recycle or undelete function that I know of.  

John