Updated My cloud from Firmware 03.01.04-139 to 04.04.03-113 and now I can't access shares

I updated my MyCloud Firmware to the latest release and now I can’t connect to any of my shares through Map Network drive?

Are you having trouble accessing existing mapped Shares? Or are you having trouble creating new mapped Shares?

If you can access new mapped Shares then remove the existing older mapped Shares that you cannot access and recreate them.

If your My Cloud does not have a static IP address it is possible that post firmware upgrade reboot the My Cloud grabbed a different IP address which may cause potential problems with existing mapped Shares.

I tried to create a new share and I can not access it. It asks me for a Username and Password yet it is set to public access. I also cannot access any of the shares created before the update 50+. I also can’t go back to the original firmware it says Invalid Firmware.

It’s a Model WDBCTL0020HWT

I’ve tried reinstalling the firmware same issue. I tried redownloading and reinstalling same issue. I can’t connect to any share though Windows 10 with Map Network Drive. The webportal works and shows each share has data. But I can’t connect to any of them. It is hook only to our local network and kept the same IP. I’ve tried connecting to shares that exist before the update with users made before the update as well as New users and shares created after. When I go to connect a network drive I type in the IP like \\JimmysVideos and a box come up with a username and password no matter if the share is public or not. I try any of the tons of username and passwords of user accounts and nothing. It says invalid username and password.

Did you try to disconnect and then reconnect those shares as Bennor suggested?

What are the access control settings for those users and shares? They may have changed due to the firmware upgrade. (Dashboard/Shares/Set Up Shares/User Access).

As admin, give yourself access to all shares.
Then disconnect all the mapped shares on your computer, and reconnect them, using your MyCloud admin username and password. Connect to a private share first, not the public share. Make sure you are asked for username and password.

I’ve done all of that.

My apologies: I can only make suggestions of things you haven’t reported you have tried.

No problem I understand. I try to post everything I did but I miss some stuff.

I can access the shares with newly created user. Public shares no longer can be accessed without username and password. I think as long as you have one that is accepted you can get to public access shares. All the other accounts can’t access anything. You put in the username and password and it rejects it. Then it acts like it accepts it and throws a another username and password box for that says Network Login for 192.168.0.X.

Windows only allows you connect to a NAS with a single set of credentials. You cannot ‘mix and match’ credentials to access different user shares; the one user you pick to use must have access rights to any Share you wish to map.

If you connect to Public first, and don’t enforce the ‘connect as other user’, it will connect and associate your Windows user credentials with the NAS. Thus, you will not be able to connect to a Private MyCloud share that does require credentials.

That’s why you need to disconnect all mapped drives, reboot the PC, and then re-map shares, forcing it to use your MyCloud user credentials.

I know this. I have used like 6 PCs and rebooting 10s of times.

i did the 40 sec reset after the last failure and all my problems gone

This problem is now gone. I have little idea what fixed it but now the shares and accounts work. Thanks everyone for helping.

1 Like