Updated Firmware, Lost all my media

Up until now I’ve been happy with my mybook live. I’ve been using it as a time machine backup drive and a place to store all my media for use through my WDTV live/ xbox.

updated the firmware after updating my mac to mountain lion a few days ago to get the time machine working again. Decided it was time to watch a movie this afternoon…

…Oh wait, where have all my files gone?

ALL of my media, Every last sodding byte of it, has disappeared. Anybody got any idea as to why? Because all I’ve done is update the firmware. I literally have not touched ANYTHING else.

I’m so annoyed right now, It took me forever to build up that bank of stuff, and there’s a few things in there that are totally irreplacable.

Log in via SSH, and go look in the “shares” directory and see if, in fact, they’re gone.

Not sure what’s meant by this. I can access from the browser based dashboard, and by the usual navigation from WDTV and Xbox, but unable to find my old media folder in any of them

EDIT:

What also strikes me as odd/ a glimmer of hope, is that when I look at the dashboard it says my timemachine share is 332gb, my public and smartware shares are practically nothing, but my overall usage is 660gb

Use one of your other backup drives to restore everything - simple.  You do have at least one secondary backup drive I assume and not simply relying on a TM backup that’s on the same HD as your data?

My TM is a backup of my laptop, which does not contain all my videos.
I have a backup of about 70% of my shows from my old non-networked drive.

The other 30% I assumed would be safe since usually a simple firmware update doesn’t obliterate your files.

Given what has happened with previous updates I personally wouldn’t have taken the risk, plus you should build redundancy into your backup strategy.

Peanuckle,

Tony mentioned looking through SSH to see if your files are there. That would be a sure fire way to know, and it sounds like they still are because of your drive usage.

To enable SSH: Go to the Dashboard with a web browser. Add /ssh to the end of the address ( http://mybooklive/UI/ssh).

That will bring up a hidden page which will let you enable SSH.

Assuming your device name is “mybooklive”, on your Mac open a Terminal. Type without the “”, “ssh root@mybooklive.local”

Password: welc0me

Now you are at the command prompt in the device. Type “cd /shares”. This will bring you to the shares you have.

Now type “df -h”. This will show you the size of all the shares. If you could post that information then we can work towards locating your media.

Just for my own knowledge, what was the name of your Media share before you upgraded and it dissapeared?

Here we go:

Filesystem Size Used Avail Use% Mounted on
/dev/md0 1.9G 539M 1.3G 30% /
tmpfs 50M 0 50M 0% /lib/init/rw
udev 10M 6.7M 3.4M 67% /dev
tmpfs 50M 0 50M 0% /dev/shm
tmpfs 50M 3.8M 47M 8% /tmp
ramlog-tmpfs 20M 4.5M 16M 23% /var/log
/dev/sda4 924G 643G 282G 70% /DataVolume

to me, none of the numbers add up if I’m reading it right.

The folder was called WDTV

It says you have 642 Gigs of data on the Datavolume – your files are, in fact, still there.

Do this:

ls -laR /DataVolume/* | more

and you’'ll see them.

Peanuckle,

Like Tony said, you information is still there. If you run the command he gave you it will list all of your files that are stored on the NAS. Looking at the size, that will be a pretty long list. 

If you start to look at them and want to stop, just press “q”. 

Could you SSH back into the drive and run a couple of commands, so we can see what the file structure of your shares looks like?

After you log in type this. Make sure you capitalise the letters, Linux is case sensitive.

cd /DataVolume/shares

ls -al

This will give us a readout of all folders. It will also show hidden folders, which I am hoping you WDTV has become.

as you guys said, I ran the suggested commands and I did indeed get a huge list of files which I got bored of scanning over,

The WDTV folder appears when I run the ls -al command, so it must still be there

Try going into the UI of the unit, then go to “Shares”. 

Create a share with the exact same name as before. WDTV.

Either you will get an error stating that the share already exists, or you might rebuild the link to the share.

It is good your data is still all there… Just getting back to it now.

1 Like

I did this, it didn’t complain about a previous WDTV folder, nor did it restore the link

EDIT:

Spoke too soon. I reloaded the UI and it’s now full of data. can find all my media in finder too. Beautiful!

Thanks for all the help guys

Kudos go to Chaos – He did far mor than me… :wink:

Awesome! I am glad you got it back.

Thanks Tony… only because you are busy helping everyone else out.