Update WD My Cloud software v. not working?

Hello all,

Just wanted to know if anyone else is having this problem:

The moment I installed the WD My Cloud software update my two laptops acessing My Book Live by wireless stopped finding the device in my network. Even the computers that acess the device by Lan seem to be working fine but get the message that remote acess is down.

The rest of the network seems to be working, I can acess the device by wireless with my smartphone, my Blue ray or my ps3…just those two laptops stopped “seeing” the device.

When I go to the web UI options page, it says Internet access - Good but in Remote Access it says “cannot establish a Remote Access connection. Make sure you are connected to the Internet (error 31520)”…

Is this because of all the problems with the WD servers?

Thanks for any help!

P.S. - I restarted the router and reconnected My Book Live and now the smartphones also won’t connect to the device…but all is good if I connect to it by FTP…I’m lost…


Did you tried resetting the device as well?

After any update is always good to reset the devices on the network to clear out any previews configuration on the devices.

1 Like

Well, today all was working again. 

I just waited a day like WD support told me by e-mail and done! I guess the problem was directly related to the servers being down.

Thanks anyway!

Same problem, WD mycloud software does not detect mycloud mirror?

Tried login manually, does not find drive?

Is it something at WD end?

Strangely now working?