Update Hard Drive firmware in DOS

Is there a way to manually update a My Book Essential 2Tb USB 3.0 firmware in DOS.  The WD firmware updater program is crashing everytime and will not start the process.  I feel that this may be the core of my drive’s issue.  How can I get the firmware re-established if corrupted and will not allow update.  Thanks.

If the drive is working without problems I would not do the firmware updates. If it ain;t broke don’t fix it.


My HD is very broken… Currently my 2Tb drive says its total capacity is 0mb… I can’t format, partition or do anything to it.  Both my Windows 7/8 systems find it fine and install the drivers for it flawlesley.  My only guess is that the firmware is corrupt and the drive does not know how to manage itself.  There is data on it that I would like to retrieve, but it seems to be in an area that the drive does not acknowledge (which happens to be the entire drive).  I am definitely open to other ideas but noone has provided me a better solution.  Btw, I have tried using DISKPART to create a partition but since it sees the drive as 0mb, It states that there is not sufficient space to create a partition.  PLEASE, HELP, ANYONE…

Something is corrupt. You can try booting from a Linux Live CD and sometimes acces files that way. If you wish to continue with the firmwware update make sure that your Adobe Flash and netframework 3.5 are up to date. Double check to see if anything else needs updating.


So I tried to access the drive using Linux and the “Disks” program but it runs into the same issue…  All options were greyed out.  It will not allow do anything since it does not see any space on the drive to format or partition.  I ran the WD lifeguard software in windows and it implied everything checked out.  I’m wondering if maybe one of the 2 controller boards (HD controller card, USB 3.0 card) is faulty.  Perhaps a surge at some point fried one of the boards.  What else would make a drive think it is a total 0mb big yet it is completely recognized as the correct drive?  Again I would like to redo the firmware, but the “firmware updater” crashes every time.  How could I do this manually?

Sadly sometimes when a firmware update fails it bricks the drive. Sometimes this 

http://www.techspot.com/community/topics/usb-drive-or-flash-problems-how-to-cleanup-and-remove-old-usb-storage-drivers.145884/will clear out coprrupt USB data. This link has some more info on testing drives 

http://community.wd.com/t5/External-Drives-for-PC/Three-of-four-new-WD-Elements-2TB-fail-WD-diagnostic-tool/td-p/540933  I can’t think of much else to try.


Thanks… I will try them…  But the second link is incorrect.  Can you please repost.  Thanks

I don’t know what happened I fixed the link.


Thanks… I’ve tried all the above.  Every inspection program sees my drive as only 0mb and cannot do anything about it.  

Still What I am looking for is a way to update the firmware without using the firmware updater program that crashes every time (Will not start the process).  How can I do it manually since automatic is not working…  

My only other idea is to buy new (on drive) circuit boards in case that is the issue.  There are 2 circuit boards on the drive… One on the drive (HD Controller) ,  One plugs into IDE (USB 3.0 Controller).  How can I verify these are good.  The WD diag software thinks its fine.

One other thing I tried which may provide some insight…? I have a powered dock to connect a IDE drive to USB 2.0 cable.  After I connected it, I tried plugging into my systems but neither (Windows 7/8) would even recognize it.  I had to re-connect its USB 3.0 circuit card to allow it to even register again.  


As I said in my other post, I’ve the same issue with my WD and I’ve already tried to change the circuit boards: no improvement…

So I don’t think that’s going to help you.

So I have a functioning Hard Drive now…  I only partially know what I did but here it goes… 

  1. Bought a used PCB board on ebay from a fried hard drive and crossed my fingers that it was still a good board… (It was the ‘exact’ same part number as mine)

  2. Tried it out when I got it.  Computer initially found the drive, then disconnected itself after about 10 seconds and would not reconnect… I tried unplugging into different USB ports 3.0/2.0  etc…

  3. At some point in all of this I tried deleting all of the drivers for the MyBook/SAS anything related… 

  4. Dejected, I tried the old board again…  For some reason it seemed to have reset something and all of a sudden it had drives size specs re-established.  Still took forever to connect, and it would let me try anything every time I connected it (took a lot of patience) and still could not use any Windows programs to re-format/partition the drive.

  5. I then decided to try Linux again (Ubuntu) from a flash drive on another laptop I have that normally runs windows 7 and only has legacy usb 2.0 ports.  

  6. Used the “Drives” program (I think) and formatted / partition to NTFS.  (It worked this time since the drive size specs had been re-established again)

  7. Went back to my windows 8 computer to use a software recovery program (EaseUS Data Recovery)…  and recovered nearly 95% of the data I thought was lost forever.

  8. Copied all data to another drive

  9. Repartitioned/formatted the WD Drive again

  10. Copied the data back to it and it seems to be working perfectly (plugged into my Wireless Router.).  

Personal Lesson:  To Backup means … (an extra copy of your info)…  not just a data drive that you keep in a safe place.  Make sure you always have data stored in at least 2 locations to avoid a potential disaster of losing decades of photos etc…   

Not sure how much this will help others but I can tell you I am a happy camper…  Good Luck all!