Update from Cloud OS 3 to Cloud OS 5 (5.11.112) is giving me the flashing blue light

Dear forum and WD support,

I have a single-drive My Cloud Device (P/N: WDBCTLxxxxx-10) and the option to update its firmware to My Cloud OS 5 popped up in its management interface. So, I decided to click on it to execute the automatic update. I have another Duo cloud device in which I had performed that operation last year and it worked fine.

This time, though, my poor little Cloud Device is stuck in the flashing blue light. It downloaded the upgrade, it applied the upgrade and said it was going to reboot but reboot never finished. I left it blinking for about 8+ hours.

I have a bit of data in it that I can’t lose. So, I need insight on the following:

  1. any way to boot from an external USB so that it comes up with dhcp and I can log onto it and scp the data out?
  2. Any way I can fix the flashing blue light without wiping out the drive?

Has anyone else had problem upgrading from OS 3 to 5.11.112?

Thanks in advance for any replies.


As for Q1, I found my answer here: Success recover my MyCloud 3TB with fast blue blinking light after update firmware!

Caveat: there’s no scp in busybox, just ftpput. Gotta live with that in case you’d like to save things out of the NAS before attempting to fix it.

As for Q2, I fixed it with the procedure from the same post: Success recover my MyCloud 3TB with fast blue blinking light after update firmware!

I then first applied firmware My_Cloud_GLCR_2.41.116.bin in safe mode and it came up. Then I tried going to My Cloud OS 5 again (automatically, just clicking on the dashboard icon) and it worked this time. Maybe WD folks fixed 5.11.112? Anyway, the thing works now.

Pointer to usbrecovery.tar.gz that works: GitHub - mcmetrox/wdmycloud-gen2: Files used to setup the software of a WD MyCloud Gen2 device

Thanks and may God help you in case this happens to you.

Same MyCloud, same situation. Hello WD support anybody home ?