Update firmware and now drive not recognize by vista


#1

Bought a WD My Book  (2TB) for some extra disk space.

It was working OK before I tried to update to firmware release 1.032.

Followed the instructions on WD support web page on how to update firmware.

Some cryptic message pop-up during the upgrade and the PC re-booted.

I am running Vista Home Premium. But now I cannot see my new drive anymore.

My Vista will try to locate the driver but could not find any.

I have another WD Essential (1TB) and this drive is working OK.

Not sure why is this happening. Maybe my firmware is stuffed up.

Please advise.

Thanks.


#2

You may not have power cycle the WD external drive and the computer after update the firmware?

Have you tried unplug the power and USB cable from the WD external drive? Wait at least 5 minutes.

Restart the computer also before plug in the WD external drive.

Doing that to make the computer release and refresh all the WD external drivers.

After you have plug the WD external drive back in.

Does it ask for new SES driver? If not, good. move on.

If yes, just say yes and click OK to install the driver

At this point the WD external should back working as normal.


#3

Thanks for the suggestions.

Tried all of that. I even tried to use the external drive on an XP PC.

No luck still the same problem.

When, saying “Yes” to install the driver, it does not do anything except it reported could not locate driver.

Anyway, WD support staff suggest the drive is stuffed and have to be reset at factory.

So created an RMA and waiting for the new drive back.