Update error - MBL bricked?


Yesterday I was watching a video via DLNA when suddenly it stopped. Afterwards, twonky was unable to find any media in the device, so I tried rebooting it, reconstructing the database, etc… with no luck.

So I decided to update the firmware to the latest version, using the UI. It stopped while downloading the new firmware, at 29% it stood still for almost 1 hour. Thinking that it was only ‘downloading’ (not installing) it shouldn’t be that important, I forgot about it and shut down the computer.

Now the device seems broken. This is the status:

  • LED light: Green
  • SSH: Not connecting (“network refused connection”)
  • Windows share: Not connecting
  • Website (UI): 404 Not found

I tried unplugging it for over a minute and plugging it again, no luck.

One weird thing is that right after the failed update, I could still access the files and SSH (but no web interface). Suddenly that stopped working too, just when I was about to reinstall the current firmware from ssh.

Any suggestion? Do you think I could access the data connecting the device to the computer directly with an twisted cable?

Does anyone know if WD provides support or replacements in these kind of situations?

Thanks a lot


Please review your private message regarding your inquiry.


1 Like