Unwanted notification "No connected devices"

Except when I’m doing a backup, I keep my My Book disconnected to avoid losing both original and backup files to ransomware, fire, etc. Every time I start my computer, I get a unnecessary message telling me that i have no “connected devices”. Is there a way to turn off that notification?

Also, I sent a question to WD support about a month ago and have received no response. Is this typical for WD support.

Thanks in advance for all help.

Hi bw3,

We would need more information for isolating this issue. We would like another chance to assist you directly in this regard. Please contact us and ask for a Level 2 agent for assistance.

Thanks for your response. I use Windows 10 Home with automatic updates, so it should be the latest version and use a My Book (3 TB purchased in Nov 2017) with the WD backup software to back up my files.
I have three questions.

  1. Is there a way to turn off the “No Connected Devices” notification that comes up every time I start my computer? I store my My Book elsewhere between backups to prevent losing both the original and backup files in case of fire or theft. I get a notification on my calendar when it’s time to do a backup, so the “No Connnected Devices” notification is a nuisance.

  2. Is there a way to set the number of versions of each file that are kept in backup and purge older versions?

  3. I would like to keep a system image on the My Book also. Is there a preferred way to separate that from the backup files - separate directory, partition, etc.?
    Thanks in advance for your help.
    Bill Wards