Unusable HDMI output at 1080P on new Live Hub

I just purchased a WD Live Hub this evening.  I got home, hooked it up and it booted without trouble.   I got a prompt that a new firmware was available (2.05.08), so I ran the update.  It downloaded the update and rebooted for the install.  From that moment on, the HDMI output appears to have ‘broke’.

The image constantly flickers on the screen.  Most of the time, the screen will be black and ever 5 - 10 seconds, it will ‘flash’ and image on the screen.  If I connect via component, it works fine.  I verified it updated the firmware and also update to 2.06.10.  The problem continues, when the HDMI output will not function correctly.  I also reset using a paperclip in the bottom hole, but that doesn’t appear to have fixed anything.

I confirmed that the unit is configured for 8-bit color over HDMI, as I noticed people had issues setting it to 12-bit.

Any help would be GREATLY appreciated!

My TV is a Sony SXRD KDS-50_A2000 _


I just found that if I set the resolution to 1080i/60 then the flickering stops.  I have a 1080P television and all other devices I use work fine at 1080P.


So is the problem occurring only if you set HDMI to AUTO?   

Or is it also happening if you MANUALLY set it to 1080P?

Just for giggles, it MIGHT be worth your while to go to Best Buy and buy a top-quality HDMI cable.   1080i uses less bandwidth than 1080p on an HDMI cable.

If it WORKS, then you know the issue is the cable.   You don’t have to KEEP that high-quality cable, you can try others.  (I’m fond of Amazon’s BASICs) but it could point you in the right direction.

If it doesn’t work with a top-quality cable, then it’s NOT a cable issue. 

12-bit color works if your TV supports 12-bit color.   Some people’s TV’s DONT, and they never knew it.

The only time you CANNOT use 12-bit color is if you enable the FRAMERATE MATCHING mode.   Then it forces 8-bit only.

The problem happens on AUTO and 1080P/60.

I’ve tried 4 different cables.  All 4 cables work perfectly with other 1080P devices: PS3, Xbox360, AppleTV and previous media streamer. 

I’m going to call WD tomorrow morning.  I’ve heard that if I boot the device with a USB drive connected, it will write out a debug log.  Is that correct?  If so, I’ll do if before calling so I can provide them as much info right away.

I understand your disbelief…   Other people have reported success, though, so I thought I’d throw that idea at you.

Another alternative is to try your same Hub and cables on a friend’s TV and see if it’s better?   I guess it’s possible you have a bad Hub, but I doubt that a bad HDMI port would only affect one setting.

No, it won’t write a Debug Log just by virtue of having a USB device attached.

In fact, you can do a Debug Log WITHOUT a USB drive, but I’ll let WD tell you how to make it happen.  

The second post in the following thread (from a supposed WD employee) suggests a HDMI log is created to attached USB drives.


Is this incorrect?

Given the symptom, I’m thinking this could be a handshake issue. 

Looks like the problem is a defective device.

I was able to borrow another unit from someone and I’ve been watching content on it for the past 30min or so without a single flicker.  

Looks like I’ll be exchanging mine tomorrow.

Even though your problem has probably been isolated, I can comment on the EDID data.

You have to enter a magic sequence on your remote to gather EDID data.

See this post:


That post is pretty old, so it might not be valid any longer with so many firmware changes since then…