Unstable Connection To G-Drive EV


#1

I have a 1TB G-DRIVE ev (Gen2) which when it is connected works well. What my problem is that to get it connected and actually connected is problematical.

I have to connect the drive a number of times before it is recognised. Not only at the SATA end of the cable but the USB end too. I have tried a number of cables and get the same thing. If it is connected then a slight nudge disconnects it.

The end result is that I tend not to use it especially if I am backing up a large number of large image files.

Is it the SATA connector - USB (of all shapes and sizes ) seem to fit properly as does Thunderbolt. I may just dump this drive and get hold of a Thunderbolt drive

Any thoughts


#2

This sounds like the port itself could be the problem. I’m not a G-Tech expert (I’m from the WD side of the company) but if this was a My Book or one of our other externals I’d recommend backing up your data and processing an RMA. You’ve already tried multiple cables and the symptoms sound like its a physical problem with the enclosure so trying on another computer likely wouldn’t help. The link below will take you to the RMA page for G-Tech.

https://www2.hgst.com/warranty/index_gtech_serial.do?fromGtech=yes