"Unsafe device removal" error and now My Cloud doesn't show the USB drive

I connected a USB drive for the first time to my WD My Cloud 2TB (Firmware version: 04.05.00-342) and it was working fine for a while. Then, a “Unsafe device removal” error, “Event code:1123” spontaneously appeared - I did not unplug the USB drive from the My Cloud’s USB or from power. The USB drive is a Western Digital My Passport Ultra 2TB, NTFS file system.

Now I cannot get the My Cloud to recognize the USB drive. I’ve tried rebooting the My Cloud and resetting it (pin into the reset hole on back for about 5 seconds). I’ve tried unplugging and replugging i
into the My Cloud. When I attach the drive to my Windows 10 laptop the drive has no problems.

Any ideas, please?

If the drive is formatted for NTFS, use Windows 10 to run a scan on the drive and fix any errors it finds. Then attach it to the My Cloud and see if it is recognized.

Thanks for the suggestions, Bennor.

Unfortunately, after a chkdsk /r, which found no errors, I reattached it and it still isn’t recognized.

im having the same issue, its a brand new wd hard drive
im on my cloud ex2 ultra with another wd elements by usb and suddently at 3 am (i believe its when plex indexes stuff) suddently i get a warning saying it has been removed unsafely with code 1123
maybe its due the power supply?

after i reboot the nas it seems to identify the usb disk again even without messing with cable or anything

As all my ‘external’ USB drives are relatively-new, and have never been problematic when plugged-into any device other than the ‘My Cloud EX2 Ultra 2-bay’ NAS, it is alarming that these same drives are being routinely ‘unsafely’ ejected within half-an-hour of being plugged-in.

Why does usually-routine and standard functionality always seem to be beyond the operational-capabilities of the ‘My Cloud EX2 Ultra’?

As I observed in my very-first post in these WD forums, the current year is 2021 - not 1995