Unresponsive remote and HD Eject

After a week of no issues, tonight I am unable to use the device. The remote wont turn the unit on, I have to unplug and replug for it to start. Once it starts, the remote only works occasionally. And when I connect the 500gig hard drive to it, it immediately asks which device do I want to eject, and I cannot exit this screen. Anyone have similar issues or ideas?

Thanks in advance.


I Assume you have done the obvious and checked the Remote for Stuck buttons or flat batteries?

I did… Even so, the fact that immediately after I connet the hdd I get prompted to ‘eject the device’, tells me there is a larger problem. I plan on exchanging it today.


I am also having the same problem.

How does this problem solved?

Is there any one who solved this problem without returning the device?

Welcome to the forums.

There were issues with some remotes not working – you might do a forum search – but the only fix is to exchange it for a remote that does work (WD will do this or you can return your Live to where you bought it for an exchange).