Unknown Partition

MyBook World II 2TB

I am having very bad luck with MyBook drives. I replaced a unit with a failed drive in it and now that unit is giving me problems too. I have already gotten an advance RMA replacement on it, but I need to get my data off the drives. I figured with it being mirrored, at least one of the drives should have my data. I can’t access the drives through the unit itself. Not sure why though. I have gotten different light patterns such as top and bottom white lights alternating on and off, and  all lights flashing on and off together every half second. Not sure what these mean, as the manual doesn’t really help. So, I tried pulling out the drive and connecting it to a SATA-USB bridge and plugging it into my desktop computer. The paritions show up in Windows Disk Management, however, the partitions show as “Unknown Partition” and so I can’t access it from Windows either. What type of parition is it? Tech support said it’s supposed to be NTFS so it must be corrupt. I ran TestDisk and it reported it as a Linux partition. I don’t really care either way but I just need these files off the drive. It pretty much defeats the purpose of having a RAID mirror if I still can’t recover anything!

If the partition type is Linux ext2 or ext3, then you may be able to see your files from a Windows box using a driver.

Ext2 Installable File System For Windows (freeware):

“Does the Ext2 driver access Ext3 volumes, too?”