Unknown error when sending external link for file

Hello,
I want to share a file from to my NAS to my sister, I used to do that without problem, but I can’t do it anymore
With the iPhone app, when I use “Share the link” to send an e-mail, I have an error, and if I use the website, I also have an unknown error “and please contact WD support (200000)”. Same error if I directly use the “Get the link” tool…
I just added a 4 TB HDD 3 days ago, and set my 2 disks in a RAID1 config, I had no problem when I only had 1 HDD in the device
Do you have any idea about the origin of the error ?
Thanks for your help

Can you access your files normally while on your local network? What happens if you disable and re-enable remote access in order to reset access permissions?

Yes I can, I can access through files.mycloud.com without problem, and my phone too, the files are present and accessible. I only have the problem when I try to share a file.
I deleted the MyCloud.com account from my admin page, created it again, and still the same problem, error 20000.
See the picture
http://www.casimages.com/i/170518112220898085.png.html
(sorry the message is in French, but I hope you’ll understand it).
I can upload a snapshot of the the iPhone message error if it can help…

Never mind, I don’t know what happened but I tried again today and it looks like it’s working again like a charm… But I still don’t know what was the problem ^^