Unit overheats, inaccessible, now how to save data?


#1

I purchased a My Cloud Mirror 8TB unit about a year and a half ago. It had been working relatively reliably except occasionally it would disappear from my network (though it has a fixed IP). After the newest My Cloud 3.0 software (and firmware 2.10.310) update, I started also using the media server capabilities but started noticing it would disappear from the network even more frequently. To remedy, I’d have to do a hard reset to the power. Then, the other week I noticed a red flag in the Diagnostics section of the web app, and it indicated that there had been a fan failure and to contact WD Support. I did, and requested an advanced RMA as I’d like to move over my data to a replacement unit before sending in the original one.

I have the replacement unit which seems to be working pretty well, except I’ve noticed that even it starts becoming unresponsive and very slow. When I checked the hard drive temperatures in the diagnostics it reports the drivers were at 56C! That’s VERY hot. The mechanical room where my machine rack and these drives were in can tend to get a bit warm since it’s where our furnace is, but at most about 85F (well under the 95F spec). And even at 56C showing for the drives, the RPM of the fan is shown at 0 RPM. I then discovered and read through this entire thread which seems to echo the exact issues I’ve been seeing with both my older unit and my new replacement. I logged in with SSH and was able to manually turn on the fans and get the drives down to the mid to low 40C range. The drives seem to be more responsive with the fans constantly running, so I plan to purchase one of the aftermarket USB fans suggested in that thread for the replacement unit to keep it operational. I find it really sad that this hasn’t been addressed by WD - clearly even with the Red drives that come stock in the Mirror, the heat does cause the unit to be extremely slow.

So, my dilemma now is that I’m not able to recover the content from my original unit to copy them over to the replacement! The old unit will power on, but when I first try to log into it, it gives me a warning in red type that says power was reset to the unit so it has to do an file system check. That lasts about 10 minutes until it finally allows me to proceed with the login and it starts to load the user interface for the web app but then it stalls. In other words, I can’t actually log in to any of the admin panel to even change any settings or see what’s going on. I can tell that it is trying to rebuild the RAID1 because both drives are constantly going at it. I suspect this is why it start to get hot again. I am able to log in via SSH to the unit, and check the temperature and turn on the fans as needed. I can also run cat /proc/mdstat and see that it is trying to rebuild the RAID, but is going EXTREMELY slow:

Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md1 : active raid1 sda2[0] sdb2[1]
3902822264 blocks super 1.0 [2/2] [UU]
[>…] resync = 0.8% (32906048/3902822264) finish=1399628.9min speed=46K/sec
bitmap: 1/1 pages [32KB], 262144KB chunk

md0 : active raid1 sdb1[1] sda1[0]
2097088 blocks [2/2] [UU]
bitmap: 5/16 pages [160KB], 8KB chunk

unused devices:

So at this rate, I’ll have my drive mirrored in oh… just under 3 years!! What the heck? All I need to do is have the drive operational enough to copy the files over to my replacement drive once. But until the RAID rebuild process completes, it seems the drive is completely unresponsive. I can’t access it through Finder on mac, it will not respond through the iOS My Cloud app, and I can’t log into the web admin panel.

Any suggestions? Is there a way to stop or disable the RAID rebuilding process from the command line via SSH? At this point I’m not too concerned about the redundant mirror drive for this unit, I just want to save my data.

I love the features of the My Cloud Mirror, I just wish I could use my replacement drive and feel confident that the data will be safe!


RAID rebuild taking days/weeks/months/not working?
Question regarding the FAN used by WD My Cloud EX2
#2

Hello there,

I have not tried this, however lets see if another user can share some tips or information on this matter. I would like to know if you have tried doing a restore on the device to see if this helps, a system restore. Here is a link that might help you with this procedure:


#3

Thanks ArMak for your suggestion - I might have thought to try that had I been able to log into the admin panel!

An update from my side: I left the RAID rebuild process continue while I awaited any responses and when I went to check on it this afternoon, I discovered it was at 67% and going at a rate of 35,000K/sec! Not sure why it decided to work much faster, but it is going at it now and with my fan set to speed 4 for the last day or so, the hard drive temps have stayed around 45C. As I write this, the rebuild process is at around 85% so I’m hopeful by tomorrow it will be completed and I’ll be able to access the files through a network connection.

One question - when I was able to access files through the network previously (before it got stuck rebuilding the RAID, and before I found the manual method to turn on the fan to keep it cool) it would start copying files and then eventually freeze up and become unresponsive. I’m hopeful that with the fan on, once it’s done with the RAID rebuild I’ll be able to copy all of the files off the drive through the network. BUT, if I get the same situation, is there any other way to extract the data? From what I understand I can’t remove one of the drives and put it in another SATA enclosure and attach it to my Mac, right? Any tricks?


#4

As an update - the RAID rebuild finished early this morning which is great, and I can log into the admin panel now and I can access the NAS through Finder on my Mac.

So, I decided to start copying a folder of 250GB from one My Cloud Mirror to the other. It’s been 4 hours and only 9GB have copied, and Finder is estimating “4 days” :frowning: And the estimate is growing as time goes by. Temperatures are holding steady with the fans manually turned on, so I don’t think it’s that.

There must be a quicker way to get this data moved to the other unit? If I enable FTP on a share and use command lines through SSH directly to the other unit instead of using a third device (my Mac), would it speed things up any? Can I remove the drive and put it in an enclosure and load it into an Ubuntu instance on VMWare? Should I remove both drives and place them into the replacement My Cloud Mirror unit temporarily and copy the data to an external USB drive that I attach to it (and is that even possible to do directly)? At this point I feel like my data is being held captive and I may need to look at alternatives - it’s not building confidence that the replacement unit WD sent me will be a solid solution for me.

By the way, the moderator escalated this issue to WD support a couple days ago but I haven’t heard from anyone yet - perhaps they’ll have some suggestions as well. If I don’t see progress on the transfer or hear from support later today, I may try canceling the file copy and trying ArMak’s suggestion of doing a system restore and seeing if that makes any difference.