Unionfs-fuse on WDMyCloud?

Hi,
I am running a WD My Cloud with an USB attached external disk.
The OS is:
Linux WDMyCloud 3.2.26 #1 SMP Thu Jul 9 11:14:15 PDT 2015 wd-2.4-rel armv7l
I ran “apt-get update”, “apt-get -f install” , and then “apt-get install unionfs-fuse” which installed the packages.
However, starting union-fuse on the command line returns with “Killed” immediately.
Any idea how to debug that would be appreciated.

Alternatively, I tried to install mergerfs. No success there either. Needs to be built on the device and tools are not all available.

Thomas.

The My Cloud firmware, while it runs Linux, has been customized by WD. Running apt-get commands tends to brick the unit particularly (on the single bay My Cloud units) when trying to install modules or update modules that are present within the WD customized firmware.

You may need to look into using the GPL firmware that WD has made available for your My Cloud unit and see if you can roll in the module you need that way then build/compile the GLP into firmware file to load to your My Cloud.

The neat thing is someone created a FUSE file system called acd_cli that allows. Additionally, you can create a unionfs mount so that writes are instan.

Dinar Guru