Unfortunately wd2go.com has never worked for me!

Hello Community,

wd2go.com has nerver worked for me since the day i bought it. I use Mac OS X 10.9.4.

But every time I logged in wd2go.com only finding that my shares aren’t displaying. And I have already followed this help  http://wdc.custhelp.com/app/answers/detail/a_id/10392/  and using Safari Browser, but it won’t help.

Are there any ideas?



Have you tried using the Desktop App?


I posted this in another thread not long ago. I don’t know if this is really the same issue, but… maybe it will help:


Basically I was able to get wd2go.com to work by (1) using Java 7 with security set at “Medium,” (2) using Firefox (despite the WD recommendation to use Safari), and (3) making sure nothing was blocking the Google Analytics tracker. Again, not sure this is really what’s going on in your case, but it’s my $.02 worth.

wd2togo worked fine for me until the new firmware

Now it doesn’t work at all.

Any remote access now blows mycloud off my local network - and it’s pretty good at disconnecting from the local network without remote access too

Well, fortunately I had enabled SSH access before the v4 clusterbomb started. I’m not a Linux expert, but I am comfortable enough using Terminal occasionally to do things I can’t do in other ways, as long as I know exactly what I’m doing. (I.e., when a forum post says, “Just type this in Terminal: ‘sudo [this that gobbledygook],’” my immediate response is “uh, no thanks.” But fortunately I had turned on SSH thinking that one day I might need command line access… So with extreme caution I carefully digested the posts that detail how to downgade to v3, took a deep breath, and went ahead and did. I’m back in My Cloud v3 Nirvana, and I have my good old drive back. Stroke of luck that I had SSH enabled. I haven’t tried yet, but I imagine my solution to the wd2go.com problem will still work since my drive’s back to its old happy self. If you didn’t enable SSH, I really feel for you, man. If you did have it enabled, my experience suggests a manual rollback to v3 is worth trying if you can stomach it.