Unexpected error 0x8007003b

I do have a Mac and everything with the WD MyCloud Mirror drive works fine.
Up until this time it worked well on my Windows 10 PC as well.
I installed the latest firmware 2.31.204

Network configuration on my WD drive:

  • IPv4 Network Mode: DHCP
  • Link Speed: Auto
  • Jumbo Frame: OFF(1500)
  • FTP Access: OFF
  • AFP Service: ON
  • NFS Service: OFF
  • WebDAV Service: OFF
  • SSH: ON
  • Dynamic DNS: OFF
  • Local Master Browser: OFF
  • Max SMB Protocol: SMB 3
  • LLTD: ON

The speed at which it copies or moves the files is ridiculously slow until it stops completely.

This is what I’ve tried:

  • Disabled Windows Firewall, ran a security scan through many different anti-viruses
  • No registry to delete found on \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WINEVT\Channels\Microsoft-Windows-Dxp…
  • Switched SMB1/2/3 = none worked

Any help solving this error is hugely appreciated, thank you!

Small correction: The drive is extremely slow now—no matter the machine (mac vs PC).
It’s NTFS formatted and I did not change the configuration of my setup. It just renders the whole NAS unusable.