Unexpected error 0x8007003b and packet loss from NAS>PC but not the other way around

I tried to move files over to my WD My Cloud Mirror 2x2TB, 2nd gen from both Mac and Windows 10 machines and I run into very slow speeds.
I have Netgear Nighthawk X6 R8000 (Gigabit router, triband, 6 antennas) and Netgear Nighthawk EX7700 extender. My ISP uses VLAN tagging to connect to the internet via fibreoptics.
I installed the latest firmware 2.31.204

All the LEDs on the NAS are blue.

Network configuration on my WD drive:

  • IPv4 Network Mode: DHCP
  • Link Speed: Auto
  • Jumbo Frame: OFF(1500)
  • FTP Access: OFF
  • AFP Service: ON
  • NFS Service: OFF
  • WebDAV Service: OFF
  • SSH: ON
  • Dynamic DNS: OFF
  • Local Master Browser: OFF
  • Max SMB Protocol: SMB 3
  • LLTD: ON

The speed at which it copies or moves the files is ridiculously slow until it stops completely.

This is what I’ve tried:

  • Disabled Windows Firewall, ran a security scan through many different anti-viruses
  • No registry to delete found on \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WINEVT\Channels\Microsoft-Windows-Dxp…
  • Switched SMB1/2/3 = none worked

Any help solving this error is hugely appreciated, thank you!

Small correction: The drive is extremely slow now—no matter the machine (mac vs PC).
It’s NTFS formatted and I did not change the configuration of my setup. It just renders the whole NAS unusable.

Here’s what I tried:

  • Disabled Oplocks for the Share
  • Change transfer unit size on the router to 1470 (down from 1500)
  • Changed wifi channels so there’s no interference.
  • Tried sitting right next to router and turned off the extender.
  • Changed the cables running from router to NAS.

Here are some further details on my setup:
When I ping the NAS from PC it receives packets.
When I ping the PC from NAS all packets are lost.
When I ping any other device on from NAS it’s all good.

Speeds I’m getting on PC:

From another laptop, Mac Pro 2019: