Unbrick Unsuccessful Unknown reason

My WD My Cloud (single 3TB drive) stopped working recently. I don’t remember the original symptoms other than I could not access it thru SMB, HTTP, or SSH. I took it apart, connected the drive to a USB adapter, and in Linux Mint was able to recover what I wanted from it. I checked the SMART data and it looked good, no bad sectors, no sectors remapped, or other concerns.
I downloaded the .img file for the 3TB model, and followed the instructions I found here to reimage it, reassembled it enough to test it, and powered it up. Started with a yellow LED that went to blinking red after about a minute. Still could not access it via HTTP or SSH, and checked the router to find it never requested an IP from DHCP. MAC did not show up in a full network scan.
Hooked it back up to Linux Mint, looked at the drive, and all the partitions appeared to be as they should. Ran checks for file system errors and bad sectors, and rechecked SMART. All good, no problems detected. Ran SpinRite on it, no problems detected.
So wiped all partitions, and started over with the unbrick/reimage process. Hooked it up to the WD My Cloud board and tried again. This time the LED went solid red after a minute. Still couldn’t access it. When listening to it carefully, can hear what sounds like the heads seeking back and forth across the platters.
Hooked the drive back up to usb and this time ran a bunch of tests on it under Windows. No problems. So I am convinced the drive itself is good. Found a different set of unbricking instructions and followed those (very carefully), put the drive back on the My Cloud board, and got the same thing. (Red LED, can’t access, sounds like head seeking).
Found yet another set of unbricking instructions that were much more detailed, and included recreating all the partitions from scratch thru Linux Terminal. Followed those instructions, tried again, and once again, got red LED, no access, and seeking noise. Tried hard factory reset, same thing.

So… Has anyone see this before, and resolved it? What further troubleshooting could I do to hopefully find and fix what the actual problem is?

Do you have first or second generation of MyCloud?
Gen1: Firmware v03.xx or v04.xx, SN ends with “0000” and start with “WDBCTL”
Gen2: Firmware v2.xx, SN ends with “0010”, start from “WDGLCR”.
All info and instruction here: https://fox-exe.ru/WDMyCloud/

Try to rebuild partitions on HDD, but before “parted” commands - do this:
dd if=/dev/zero of=/dev/sdb bs=1M count=10000
!! Replace “sdb” to your disk number !!

If still fail - buy cheap “USB - UART adapter” (Based on CP2102 or FT232RL), solder/connect it to device and see what happend on device while its boot. Post full boot log here (Attach log file or use pastebin.com)

Even when you get a red front LED, try accessing the My Cloud Dashboard (http://wdmycloud or http://wdmycloud.local) then perform a system reset. Or try performing a 40 second reset using the reset button on the back of the My Cloud.

1 Like

Sounds like you have the “corrupted auto firmware update” bug. Is this what you tried:

Confirm you have the 2nd Gen MyCloud before doing this.

Good luck!

First, let me note that although I was pretty sure the problem was not the hard drive, I tried another one anyway, along with another copy of the image (probably the same image) downloaded from a different source. And yes, I got the same results.

Bennor: My My Cloud is never connecting to the LAN and never gets an IP address so I cannot get to the dashboard by any means. And I have done multiple hard resets. But thank you anyway for the suggestions.
Fox_exe and sktn77a: My My Cloud is definitely a first generation. I bought it not long after they were first announced, it’s over 5 years old. The PART# begins with WDBCTL and ends with HWT-00. (The SN ends in 6905)
Fox: I am very familiar with USB TTL adapters, and have several 'cuz I tinker with microcontrollers. I had a hunch the My Cloud might have a serial debug port, but didn’t know where or the pin out. (Found your other posts with pics) so thanks for that info! I’m pretty busy the next few days but I will try that later this week. I’m quite curious as to what info it will spit out!