Unbrick then Firmware Upgrade Equals No Dashboard

Hi All,

While i have done this unbricking in the past, about 2 years ago.
Im tyring the same thing today. However after unbricking with the backup firmware and then upgrading to 4.x firmware. Im losing the dashboard. I’ve already tried teh “gdisk” to correct the GPT. I recall this did work two years ago.
Any clues what could be going on. Im basically replacing the disk in my wdmycloud.

I found that I had to fix the GPT first, step 2 of the directions I posted above. I also found I had to follow the steps I posted above exactly. Once I had to do it twice before it worked. I also used an Ubuntu LiveCD and not a Gparted boot CD.

If you get GTP errors running fdisk or parted then try the following command:
sudo gdisk /dev/sdb

Then type “o” then type “w” to fix GTP errors.

Some have had luck using the following steps posted by another user:

https://drive.google.com/file/d/0B_6OlQ_H0PxVbzZac0plbkZKeGM/view

Thanks but I’m already using the steps from the word document you linked above.
I’m using Ubuntu in a VM. The hard drive is mounted via a sata to USB adapter.
I’ve tried the steps several times but everytime I update the firmware to 4.x , I lose dashboard.
I’m wondering, maybe I need to run The gdisk command after I’ve upgraded the firmware to 4.x? Does that command wipe all partitions? Or simply fixes the got table?

If possible try the unbricking procedure, or at the very least the GTP fix, outside of the VM using a Linux boot CD. Could be the VM is causing a problem when trying to run the GTP fix or other steps.

So for my own future reference and for others, after fighting with the unbrick for two days it could get it to upgrade it to the latest 4.x firmware. I would dashboard…and m previously tested procedure as in the above post didnt help this time for some reason.
Anyways at the end what worked was that, once i had the drive unbricked using the original 3.x firmware as per above steps…
1-i did a quick restore from the dashboard
2- I downloaded the very first 4.x firmware file that was released by WD " sq-040000-607-20140630.deb.zip". and upgraded the drive with that using the dashboard firmware update process.
After the reboot im on that 4.x firmware and dashboard is good. Now im not going to risj going any further as im pretty sick of this unbricking…This drive is only a back for my backup :slight_smile: so i dont need any fancy features. i just wanted to be on 4.x release as the samba file transfer speeds are twice as on firmware 3.x.