Unbrick then Firmware Upgrade Equals No Dashboard


This seems to be an issue for some of us who unbrick the WD My Cloud using the original_v3.04.01-230.tar.gz file then perform an upgrade to firmware version 04.04.01-112. The problem is such posts get lost among the rest of the posts/thread where people complain about not being able to access the My Cloud Dashboard because the My Cloud IP address has changed. That is not the case here! In all cases the Dashboard is not accessible via multiple computers (Windows 7, Windows 10, Android mobile devices) using multiple browsers (Windows Explorer, Firefox, Chrome) at either the unit’s IP address or via http://wdmycloud/.


Due to initial 4T drive that came with the My Cloud unit becoming damaged and non-mountable (due to loads of bad blocks/bad sectors) used a spare hard drive, followed the unbricking procedure earlier this year and was, eventually after several unbricking attempts, able to upgrade the firmware to the current version at that time. Recently, while fooling around trying to troubleshoot why several of my external USB drives mount improperly via the My Cloud USB port under the OS 3 firmware, I bricked the My Cloud. More details on this USB/OS 3 issue is discussed at the following link: https://community.wd.com/t/not-solved-usb-my-book-not-recognized-0k/96850/36

Initial Unbricking Process:

Initially used the directions from this link: https://drive.google.com/file/d/0B_6OlQ_H0PxVejVic2ZubXBfbHM/view?pli=1 to “unbrick” at first a 250GB then subsequently a 1T drive for use in the WD My Cloud enclosure.

Drives Used:

Hitachi Deskstar model HDT25025VLA380 - 250GB drive
Seagate model ST31000333AS – 1T drive.

Computer/OS/Hard drive connection used to perform upgrade:

Home built Windows desktop PC
Ubuntu 14.04 x64 Live CD (booted to Ubuntu Live CD)
Hard drive connected via internal SATA connector in desktop PC.


After “unbricking” either drive and then immediately performing a firmware upgrade to the latest version the Dashboard no longer loads. Forced to reload the “.img” files from the original_v3.04.01-230.tar.gz file via the following Linux procedure:

dd if=kernel.img of=/dev/sdb5
dd if=kernel.img of=/dev/sdb6
dd if=config.img of=/dev/sdb7
dd if=config.img of=/dev/sdb8
dd if=rootfs.img of=/dev/sdb1
dd if=rootfs.img of=/dev/sdb2

Steps Performed Post Initial “Unbrick” with v3.04.01-230:

Note: In trying to do this as any non technical/non geek person would do, I did not turn on or off, enable or disable, any options on the My Cloud. Because of this trying to fix the Dashboard not loading issue via SSH is not possible.

After “unbrick” the Dashboard initially loads via http://wdmycloud and its accessible.

Because Capacity is wrong, performed a System Only restore (Dashboard > Settings > Utilities > System Only button). No other changes made.

Post reset, Dashboard is accessible and capacity is correct. Performed firmware upgrade to latest firmware version (currently 04.04.01-112) by selecting Dashboard > Settings > Firmware > Update Now. Note: Upgrade took a long time, over 15 minutes, before unit rebooted.

Post reboot, white LED for at least five minutes before turning blue. Web browser still indicating rebooting.

A minute or two later web browser changed from “reboot” to indicate the following:
• Timeout; waiting for reboot. Verify that the LED on the front of your device is not red; then find the device on the network and reinitialize the web user interface. If the LED is red, reboot your drive manually. (31001)

Reloaded web page (http://wdmycloud/) and Dashboard fails to load.

However, the Twonky interface (http://wdmycloud:9000) does load indicating Version: 7.2.9-6.

Windows Explorer finds the My Cloud and indicates the three default (public) folders within it. No other folders listed or present.

DLNA media client (Roku and Windows Media Player) finds My Cloud Twonky media server.

Tried the following post firmware upgrade:

  • Removed and reapplied power.
  • Performs a 4 second reset by removing
    power, pressing down on the reset button, reapplying power and
    waiting at least four seconds.
  • Performed a 40 second reset by
    removing power, pressing down on the reset button, reapplying power
    and waiting at least 40 second.

Problem remains!!! Dashboard fails to load, while the My Cloud can still be accessed via Windows Explorer and DLNA media player clients, and Twonky administration page is accessible.

Because Dashboard fails to load am forced to go back through the process of pushing thev3.04.01-230 “.img” files to their respective hard drive partitions all over again to revert back to v3.04.01-230.

If I unpack the rootfs.img file from the latest firmware file (http://download.wdc.com/nas/sq-040401-112-20151013.deb.zip) and push it to /dev/sda1 and /dev/sda2 the My Cloud unit fails to boot up, shows only a white LED light that blinks once every minute or so with no network access indicated via the My Cloud’s Ethernet port LED’s.

Further Questions:

  • Have others experienced this issue? What steps were taken to troubleshoot the issue?
  • What steps, if any, were performed that lead to a successful upgrade to latest firmware?
  • What post upgrade to latest firmware issues remain, if any (like USB failing to mount properly)?
  • Is there an official WD downloadable file containing the “.img” files needed to “unbrick” a hard drive?
  • If one has SSH active, what can be done (commands, file edits, etc.) via SSH to trigger the
    Dashboard to start loading again?

Note: There are several methods for pushing a new firmware or downgrading to older firmware via SSH discussed elsewhere.

Further observations: Some indicators that an upgrade or unbrick failed. If the LED blinks once every minute. The LED indicators on the network port are not lit up, or only one lights up occasionally.

1 Like

hmmm… I thought it was a how-to… so I gave it a heart… to find… that I think are questions on why the dashboard is blank?

I had the exact issue you describe. Ages agoI bricked my Mycloud andhad to rebuild my partitions and dd the seperate images files to each partition this put it on version 2.30 I think which all worked ok. The problem came when I then tried to upgrade the firmware to the latest version no matter what I did I could only get the dashboard for the first few minutes and even then with loads of error messages. I was pulling my hair out until I figured out why. The method described for rebuilding the partitions on this forum (the one thats on the google docs in russian) seems to have or introduce errors not sure where it might be the images or the partition build in anycase it won’t upgrade correctly and you have more and more issues as time goes on.

How to resolve

Remove drive and connect it to computer via USB or esata.

Download and install parted magic to a usb stick and boot to it. Search for pmagic_2013_08_01.iso
This is much better than gparted as if has wifi and so many other useful items.

Backup your data from the ext4 partition.
Unmount md127 if it is showing in the gui partition program via command line.

Remove all partitions
I also removed the superblocks.
Format drive to no file system (the black one) this should only take a few seconds again do this from the gui but make sure your formating the correct drive in my case it was sdb.

Download the full disk image and extract the image (seach google for mycloud2tb_transmission_v03.04.01-230). Open the terminal at that location and then dd it to your my cloud.

dd if=/mnt/hd3/WDC/mycloud2tb_transmission_v03.04.01-230.img of=/dev/sdb (sdb is my mycloud drive but confirm this before you do it or you might overwrite your computers HD) takes about 30 mins.
This was a prehacked image that included transmission but dont worry when you get to update the firmware it will return it to the stock version.

Rebuild drive and boot then
Do system only restore via the mycloud ui.

Then upgrade your drive. I did it via the Mycloud app not my PC but not sure that made any difference.

Give it time to complete than dashboard
will work and you will be on latest firmware.

Basicly all you need to do is format the disk to no file system and remove any superblocks.
dd the image from terminal
rebuild and boot
system only restore
then update.


1 Like

@Adam2311, tried your method. Didn’t work unfortunately. Maybe it will for others. Tried it several times and each time it corrupted the GPT entries of the 1T hard drive I was using for some reason. Each time the My Cloud would boot to a white LED that would blink once approximately once a minute and the Ethernet LED ports were not lit up.

When the GPT entries got corrupted I wound up using gdisk (hitting o then w in the gdisk command window) to fix the GPT entries error on the disk while in Ubuntu.

For giggles after this last time fixing the GPT entries with gdisk I ran the previous method I mention in the OP post to unbrick. This time it worked. Was able to get the latest firmware loaded and the dashboard now shows correctly. Don’t know if it was related to fixing the GPT entries or not though or just an alignment of the planets for a brief moment.

When I finish writing up my notes from this last time I’ll post the procedure that was successful for me, at least this last time in getting the unit to upgrade to the latest firmware and show the dashboard. My procedure (which may not work for others) is a bit modified from the link posted in my initial post.

1 Like

I solved the problem with the following steps:

Download the right virgin image to your computer and don’t use for example 250GB image when you have a 3TB device. I have downloaded the image from this thread:

Follow steps 1 - 7 from the following guide:

Then do the the steps explained by cnlinya:

Put your hard drive back in mini board and do a quick factory reset.

Now your volume should show the right space and you will be able to update to the last firmware update.

Good luck everyone :+1:

On a side issue, my problem with USB loading with certain external USB drives persists.

Back to the topic at hand. I’ve had problems with most other methods of unbricking when using an alternate hard drive from the one included with the original WD My Cloud device. Its apparent that what works for one person doesn’t always work for the next person. Could be the methods that push a single “.img” file to the hard drive may cause problems if the drive isn’t the standard size that comes with the WD My Cloud. Or possibly if the drive was formatted differently prior to being used in the WD My Cloud enclosure. Or its some other issue.

What is certain is that for some, when they either unbrick and upgrade, or just upgrade, the Dashboard doesn’t load properly or at all. This appears to indicate something isn’t loading properly post firmware upgrade. Quite possibly (or not) due to some sort of GPT issue on the hard drive. It would be nice if there was an easy fix that didn’t require one to go through various methods or steps to reload the firmware from these non sanctioned, non official WD supported methods.

Below are the general steps I used which I modified from this link (from the OP post). I make no guarantee it will work for others. It worked in my instance to setup a 1T Seagate drive for use in the My Cloud enclosure. I haven’t gone back and tested the initial 250GB drive I put in the WD My Cloud enclosure that had the problem of missing Dashboard post upgrade from 03.04.01-230 to 04.04.01-12. At some point I plan to test that drive to see if fixing the GPT entry fixes the failed Dashboard loading issue. Edit to add: Just tried the 250GB drive and it too was able to correctly update to the latest firmware and the Dashboard loads properly using the directions posted below (started at step 1 and did the GPT rewrite).

One can copy the following into another document (Word or notepad) for easy use and printing out.

How to unbrick, replace or restore original WD My Cloud single hard drive firmware:

These basic directions assume you have a 4GB or larger USB flash/pen drive, a computer with SATA connectors or some form of external SATA enclosure/docking station, basic knowledge of how to boot PC using a boot disc, basic knowledge of how to use Linux.

Note: Use and proceed at your own risk!!!

• Download original_v3.04.01-230.tar.gz to a flash drive: https://drive.google.com/file/d/0B_6OlQ_H0PxVQ2l5MTNvQk1xSUU
• Used Ubuntu Live/Boot CD: http://www.ubuntu.com/download/desktop
• To avoid damaging non WD My Cloud hard drives remove or disconnect them from the computer.
• Backup any data on your My Cloud as these directions may result in the erasure of all data on hard drive.  
• Insert USB Flash/Pen drive containing the file original_v3.04.01-230.tar.gz (or it's extracted contents) into PC before booting with Linux Live/Boot CD
• All terminal commands run from Root user or Sudo. For purposes of this guide Sudo was used.
• After booting with Live/Boot CD open terminal window by typing: 
[ctrl] + [alt] + [t]
Then type:
sudo apt-get update 
sudo apt-get install mdadm parted

To install new/used hard drive start with step 1. 
To repair existing bricked WD My Cloud hard drive start with step 13.

Note: Starting from step 1 will erase hard drive contents. If hard drive contains important data, backup hard drive before proceeding.

1. Find the My Cloud hard drive name (sda, sdb, sdd, sdc, sde, etc.) by typing:
sudo fdisk -l 
sudo parted -l

Note: For these basic directions "sdb" is used. 

2. If you get GTP errors running fdisk or parted then try the following command:
sudo gdisk /dev/sdb

Then type "o" then type "w" to fix GTP errors.

3. Run parted utility:
sudo parted /dev/sdb

4. Type "print" to see what partitions exist on hard drive.

5. If any partitions exist, remove each of them by typing "rm 1" (where 1 - number of partition)

6. Create new table:
mklabel gpt
mkpart primary 528M 2576M
mkpart primary 2576M 4624M
mkpart primary 16M 528M
mkpart primary 4828M -1M
mkpart primary 4624M 4724M
mkpart primary 4724M 4824M
mkpart primary 4824M 4826M
mkpart primary 4826M 4828M
set 1 raid on
set 2 raid on

Type "quit" to exit parted.

7. Format data partition:
sudo mkfs -t ext4 /dev/sdb4

8. Reboot computer, boot back to Linux Live CD. From command line run: 
sudo apt-get update 
sudo apt-get install mdadm parted.

9. Run sudo fdisk -l or sudo parted -l and note the drive names just incase the /dev/sd* location changed.

10. Create main RAID partition, type: 
sudo mdadm --create /dev/md0 --level=1 --metadata=0.9 --raid-devices=2 /dev/sdb1 /dev/sdb2

11. Wait for RAID creation to complete, type:
sudo watch cat /proc/mdstat 

Wait to 100%. Then type:
[ctrl] + [c] for close.

12. Stop auto-loaded raid, type: 
sudo mdadm --stop /dev/md0

If /dev/md0 not found type the following to find RAID mount point: 
sudo ls /dev 
sudo grep md

13. Start normal raid (must be /dev/md0), type: 
sudo mdadm -A /dev/md0 /dev/sdb1 /dev/sdb2

14. Using terminal window navigate to USB Flash/Pen drive location. Example: /media/ubuntu/<drive name> If the contents of file original_v3.04.01-230.tar.gz have not been previously extracted on the USB Flash/Pen drive, type:
sudo tar xvfz original_v3.04.01-230.tar.gz

15. Upload backup images to WD's hdd:
sudo dd if=kernel.img of=/dev/sdb5
sudo dd if=kernel.img of=/dev/sdb6
sudo dd if=config.img of=/dev/sdb7
sudo dd if=config.img of=/dev/sdb8
sudo dd if=rootfs.img of=/dev/md0

16. A Note: If for what ever reason the My Cloud fails to boot (white LED), or problems with upgrade to newer firmware failing/not working (ex. UI fails to load) try the following alternative step.
sudo mdadm --stop /dev/md0

sudo dd if=kernel.img of=/dev/sdb5
sudo dd if=kernel.img of=/dev/sdb6
sudo dd if=config.img of=/dev/sdb7
sudo dd if=config.img of=/dev/sdb8
sudo dd if=rootfs.img of=/dev/sdb1
sudo dd if=rootfs.img of=/dev/sdb2

17. Shutdown PC from terminal window by typing: shutdown -p -H 0 Or use "Logout" from menu.

18. Disconnect hard drive from computer/external connector and connect to WD My Cloud circuit board. Then connect power to the My Cloud circuit board to turn on WD My Cloud. Boot process may take 5-10 min or longer. LED light should change from White to Blue.

Note: If the WD My Cloud fails to boot with either a solid white or red LED, then reattach hard drive to PC/docking station, reinsert USB Flash/Pen drive, boot back into Linux, go back to step 13, then proceed to step 16 to push the three "img" files to their respective partitions, shut down PC and try booting the hard drive again with the WD My Cloud circuit board. 
If the drive still fails to boot (white or red LED), the GTP entry probably needs to be repaired. If that is the case try step 2 above to rebuilt the GPT entry (will probably erase drive contents) and then perform the rest of the subsequent steps. If step 2 doesn't work then start from scratch at step 1. Backup any files if needed from sdb4 (the mountable ext4 partition containing the shares) prior to starting from step 1.

19. After WD My Cloud boots to Blue LED, access the Dashboard with web browser (http://wdmycloud/). Proceed through initial access screen then enable SSH on the Settings -> Network -> Network Services section. Often the capacity will be incorrectly listed, fix by selecting Quick Restore (or Quick Factory Restore) from the Settings -> Utilities section. The device will reboot and rebuild the system files.

20. After factory restore has been performed and WD My Cloud boots, restore any settings (like Static IP) as needed and update the firmware if needed. Be patient. If there was existing data on the hard drive it may take the WD My Cloud OS a long time to scan/catalog the files.

How Linux sees drive contents of a 250GB drive:
Number  Start   End     Size    File system     Name     Flags
 3      15.7MB  528MB   513MB   linux-swap(v1)  primary
 1      528MB   2576MB  2048MB  ext3            primary  raid
 2      2576MB  4624MB  2048MB  ext3            primary  raid
 5      4624MB  4724MB  99.6MB                  primary
 6      4724MB  4824MB  101MB                   primary
 7      4824MB  4826MB  1049kB                  primary
 8      4826MB  4828MB  2097kB                  primary
 4      4828MB  250GB   245GB   ext4            primary
1 Like

Same issue. After unbricking no dashboard, but I have SSH access, twonky is running and serving renderers, I am able to mount shares from my (windows 7) PC.
I am starting to consider to leave it this way, at least it is doing something more than being an expensive paper holder…

I did that for a while with two separate hard drives, left it at the point of running and accessible on the local network but unable to access the Dashboard. In my case, which may not work for others, it seems running Gdisk on the drive to fix GTP errors at the start of the unbrick process seems to be the potential fix when it comes to unbricking with v3.04.01-230 then upgrading to 04.04.01-112 and having the Dashboard load.

Does the above process erase all data?

Depending on how you unbrick the My Cloud, yes the unbrick process will erase all the data. the process I used and detailed above will erase all the data on the hard drive. In the set of directions I wrote above I even state the following: “• Backup any data on your My Cloud as these directions may result in the erasure of all data on hard drive.” and later in the directions “Note: Starting from step 1 will erase hard drive contents. If hard drive contains important data, backup hard drive before proceeding.”

There are certain other unbricking methods that do not cause the loss of data on the fourth partition (ext4) which contains the user shares/folders/data/files. They involve just pushing, via the DD command, the “img” files to the various partitions. But in some instances this fails because there are GTP errors, in which case fixing those errors may cause total data loss.

1 Like

So Bennor, I am still not sure if this post is a “How-to” with a caveat or a post that needs an answer?

However I will answer the following. Firmware 3.04 is a notoriously bad update and it is the firmware that we all downgrade to, it is the first firmware upgrade that made me give up all future firmware upgrade for over, almost, 2 years and it is the firmware that is used for unbricking.

The first thing that I noticed after downgrading to firmware 3.04 was that there was no dashboard and for me, the device locked me out from SSH’ing into it.

The solution for the both times that I upgraded and downgraded into firmware 3.04 was a 40 second reset.

I hope this is the solution that you are looking for because someday I plan/dream on using this unbricking procedure to restore the OS to a smaller hard drive; utilizing the 4TB in a more productive manner.

good luck…

@Ralphael, My initial post isn’t really how to downgrade from the v4x firmware to the v3x firmware. Rather its “unbricking” either an already bricked hard drive or replacing the existing WD My Cloud hard drive which has died, then upgrading to the latest firmware where the problems started.

The v3.04.01-230 firmware seems to run reasonable well post unbricking for me when I used it.

Basically what I found and which I try to explain above is that the Dashboard not loading issue (in my case) that got introduced when upgrading from the v3.04.01-230 to the v4.x firmware seems/appears to be the result of some sort of GPT error that wasn’t handled during the initial unbricking process (I tried several unbrick methods) that causes the v4.x firmware not to display the Dashboard. Post v4.x upgrade where the Dashboard fails to load, the 4 second & 40 second reset via the back reset button didn’t work. Tried the 40 second reset repeatedly.

For me the solution was to “fix” the GTP table on the hard drive then unbricked then upgrade to v4.x firmware. Then the Dashboard would load under the v4.x firmware.

good to hear that was the resolution then. When I use this unbricking/upgrade procedure in the future, I will consult with you the expert :slight_smile:

**Update, I phoned WD. After going through several steps the operator from WD informed me that the drive is done. He informed me that it is ok for me to take the drive to be data recovered and then WD will replace the drive completely once I have my data recovered!

@Bennor did you find a solution to this? I have been trying for a week to find a solution but no luck. Even tried to update to a previous firmware (than the latest available) but still no luck. I also Unbrick, firmware upgrade and then no dashboard…I did this after my HDD failed.

Yes. I explain what worked earlier in the thread, see this post. The trick for me was to fix the GTP first, step 2 in the direction I posted above.

Great! It worked, I did not try it before because I thought is was a “custom” solution, but it worked for me as well !!! Great help! Thanx!

Glad it worked. Every unbricking process is a “custom” solution since WD doesn’t officially support unbricking their devices and do not have an official unbricking process. Some, as I did, will have to try several different methods to find one that works for them.

@Bennor, original instruction here: https://drive.google.com/open?id=0B_6OlQ_H0PxVRXF4aFpYS2dzMEE
Use “Recovery” package for unbrick WDMC (No need to open device. An you can use it if new HDD installed.)
Or use “Replace HDD” if first method not work.

Ps: “Hand” method to reset device (After unbricking, for example):
touch /mount_point_for_md0/etc/.fresh_install

What does “soft brick” mean? Does everything work but the Dashboard?

Unknown if one can use the DD command via SSH to push the three IMG files to their relevant partitions. Worst comes to worst is one can simply give it try. One would of course have to copy the IMG files to some location on the My Cloud, preferably the user partition/share and then issue the DD command from there via SSH to push the IMG file to the relevant partition. It is possible the process won’t work due to the partitions being used/mounted by the firmware file system.