Unable to use on multiple computers

So I am trying to figure out why i cannot access my external hard drive from any computer except the original computer i used. It tells me i do not have permission to access the folders. I originally had a password on the drive but removed the password since my surface is not able to run the security software to unlock the drive when there is one. This has happened to me every time i have tried to use it on another computer regardless of windows version or type of computer. What is the point of having an external drive if I cannot use it on my other computers without having to share if from one computer over the network? This is quickly becoming a frustrating device.  

Oh my drive is a WD My Passport Ultra 2TB.

Welcome to the Community.

How were the files copied into the external hard drive? During a normal copy/paste operation the folders should not normally inherit permissions assigned to them unless they were previously configured in such manner. You could attempt changing the ownership in order to access the files.


If the files were copied by means of a dedicated application then it would be best to verify it transferring files requires a dedicates procedure.


I had already tried to change ownership, it just errors out saying i do not have permission to do so. All data on this drive was put there by copy/paste. Its literally just a hd full of videos and music

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country