Unable to update firmware

Hi to all
Since today I’m unable to see, in the dashboard tab, the first one, the summary of drive space and the kind of files stored, yet, it doesn’t give me a good performance, I try to watch some movie but I cannot because it stopped all the time; wasn’t like this until two days ago!
I tried to update it at last firmware version but return the message “not enough space to do it”, then I thoght the two think are connected, then I tried to make the soft reset (I don’t want delet the data stored) but seem useless.
Some suggestion before I will make a complete reset?

Did you try updating the Firmware via a SD CARD ?

(i doubt the “not enough free space” relates to firmware updating, but if you want, just delete 100MB to be sure)


How to Install the Product Update from an SD Card

  1. Download the firmware to your desktop.
    Unzip the file and you will find the actual firmware in this format: MyPassportWireless_x.bin.
  2. Format an SD card FAT-32.
  3. Create a folder on the SD card named “update”.
  4. Copy the MyPassportWireless_x.bin file into the “update” folder.
  5. Turn OFF the My Passport Wireless.
  6. Insert the SD Card.
  7. Turn ON the My Passport Wireless.
  8. The My Passport Wireless will boot up, then will start flashing a White LED while the update is happening.
  9. Once the update is complete the LED will return to the normal ON state.

I’d add that it can seem to take “forever” for the white light to flash quickly, so be patient, because it will happen, but it can take three or so minutes it seems.

…and I might add that the only way I been able to do a firmware upgrade is to connect the MPW to my home network and connect my iPhone via that network to the MW and update it with My Cloud app.

From the WEB app it can’t neither auto or manual. Havn’t tried with SD card thou. 

I (and some others) have said we prefer to use the SD card method to update – try it.

I download the firmware from the the download page and update the firmware using the web interface.

I haven’t had any problems updating that way.

The procedure (from WD’s website page) is:

  1. Download the firmware to your desktop.
  2. Unzip the file and you will find the actual firmware in this format: MyPassportWireless_x.bin.
  3. Save this to your desktop.
  4. Connect to the My Passport Wireless using Wi-Fi.
  5. Open the My Cloud Dashboard UI.
  6. Go to Firmware Tab.
  7. Under the section Manual Update, click the Update From File button and a window will open.
  8. Browse to where you saved the MyPassportWireless_x.bin file and select it.
  9. You will see a pop up confirming to upgrade your firmware, click Ok.

Hello to everyone,
As I wrote In my first post, the real issue regarded the unavailability to use MPW and have the normal performance, then I tought that, probably, with the update I could solve it. I don’t know how, but after a soft reset it update by it self to the xxx.xxx.17, anyway the performance were the same. As I wrote a symptom of my problem was that in the dashboard wasn’t displayed the cake graphic, therefore I thought that could be something on the index. I was determined to format the driver, then before that I tryed to use the “s.o.s” function in my macbookpro, was good, because after that I come back to the proper performance and the to display the information regarding the driver. Just for information, I come back to the previous firmware (xxx.xxx.15) because with last one I cannot use the DLNA function, that’s a probably bug I hope will be solved on the next release.