Unable to setup new sync folder

WD Settings has a menu item “Settings.”
Under Sync folders it has a button for “Add”

However, once I select a folder to add, after a while, I get “unable to connect to remote server” error.
The folder I’m selecting is off my D drive. Whereas the other WD Sync folders “My Documents” is on my C drive.

When I set up WD Sync, I had no problems with setting it up.
I can access files from my phone or my tablet. I recently did a remote demo, of how easy it is to access files. So I am not having problems with total remote access.

I’m running windows 7 and have the latest updates.
I have mapped my account to a network dr with no problem. (setting of perms were not allowed)
I have set up a static IP on my router to make sure none of my other devices do not grab the IP on a reboot.
My router is a Netgear router, BUT since I’m running a separate website, ports 80 and 443 are used by my webserver.

To solve a problem with my Cloud system constantly scanning, I logged in with SSH (did not open any ports, as my webserver uses port 22), found the problem file, and deleted it on the C drive. So I’m not sure if opening ports is the problem.

Any idea of what I’m missing?



If you try a different folder or drive, does the same thing happen? Also try disable remote access and then re enable it see if this helps.


I’ve tried the following:

  1. I’ve tried to select a folder on my C and D drive.
  2. I’ve tried turning off the “Remote Access”
    and then
  3. tried selecting a folder on my C drive to sync.
    At this point as before, the ‘Device folder browser’ comes up (both sides blank); a waiting circle appears; then ‘Unable to connect to remote server’
  4. I even tried dragging a small folder on C drive to the table to see if that would do it.

Currently, the only thing that was automatically set up of sync is the My Documents folder.

Throughout all of this, I do have remote access to files my WD Sync folder (actually a link back to my ‘My Documents’ folder. Oh yes, I’ve tried creating a link a folder w/o success.

Would you advise I uninstall and re-install WD Sync?


One additional thing that I tried and failed:

If I configure ‘Remote Cloud Access’ with a manual setting where Pt 1 is 80 and Pt 2 is 443, this fails.
I could still access my files remotely, but the connection status said failed.

I uninstalled WD Sync and re-installed.

Tried creating a sync folder and it worked.

SOLVED anther way.
Hi Raymond,

Thanks for your lead in this. Once I read your comment, instead of uninstalling and reinstalling WD Sync, I removed the device and then added it back in the Local Folder window above the Add button and gained the same success.