Unable to setup my book live

I’ve been using My Book Live 3tb for a number of years successfully. I recently upgraded my OS from Windows 10 pro 32bit to 64bit. When I reinstalled the software I could not set up the drive with the set up utility. It recognises the drive and the IP address but when I click next and come to the screen "checking your device…"the following error comes up:

“We’ve detected that you may not be able to… Configure the device (settings, etc.)”

I tried it on another computer and get the same error.

Windows network recognises the drive.

When I put the IP address into a browser (access the dashboard) the page doesn’t load. Also there seem to be two IP addresses depending on what I’m looking at. My router login says it is but windows and the WD programs say it is

The front light is a solid green.

I have done the whole four second paper clip in the back reset and nothing changed (other than erasing all my data, which I expected).

In WD smart ware the drive is recognised but I can’t log in to it.

What do you think is the problem here - the drive seems otherwise fine (although I can’t do anything with it yet)?

IP addresses in the 169.254.x.x address space are used by Windows (and maybe other things) for assigning IP addresses (using Automatic Private IP Addressing) when DHCP is not being used. Is it possible you aren’t using DHCP and gave your MBL static IP address

Microsoft tightened up the procedures for local networking in Windows 10. There are a couple things to look at.

  1. In Network and Sharing Center \ Advanced sharing settings
    make sure you have network discovery enabled and make sure you are using the Private (rather than Guest or Public) profile. (To use the Private profile you used to have to set “Make my PC discoverable” somewhere, but that may have changed.)

  2. Make sure NetBIOS over TCP is enable
    In Control Panel\Network and Internet\Network Connections
    double click on your network interface icon
    click on Properties
    select TCP/IPv4 and click Properties
    click Advanced
    select the WINS tab
    under NetBIOS setting, select Enable NetBIOS over TCP/IP

There are probably other things to check, too, but I don’t remember what.

Thank you for those helpful tips!
I’ll give them a go when I get home and report back.

Hi Pokeefe

  1. The settings were already there as you described so no change needed
  2. I tried this and rebooted (the Enable Netbios over TCP/IP was not selected before) - no change.

Really stumped…

I had missed that. What recognizes the drive and IP addresses? The WD programs you referred to? If so, it’s interesting that they find the drive and IP addr while the underlying networking infrastructure cannot. (I got rid of them years ago since they didn’t seem to serve a useful purpose. Maybe I was wrong.)

In your router, what is the IP address of your Windows system? And what is the IP address of your router? I assume they are both 192.168.1.x. If not, perhaps you should describe your configuration.

Can you ping either or from Windows?