Unable to reset MyBook Live via reset button on back

Evening gurus

Having read the user manual, and having been unable to get my MBL reattached to my network, I decided to try the >4s reset option. But my device still can’t be found on my network when using the WD MyCloud tools.

I’m using a NetDuma router which cleverly shows you all devices connected to it and their IP address however, there is nothing appearing for the MBL. There are three “nameless devices” on the network, one with an IP address (when pinged doesn’t appear to respond), and the other two with no IP addresses assigned.

I’m absolutely at a loss about what to do now. I have masses of photos and video stored on the drive (I’m an amateur photographer), and while I have a backup from a few months back - I would be missing some images which would be a real pain.

Is it possible to remove the drive from within the MBL and put it into a USB caddy or similar to be able to access the data that way?

Any thoughts/hints/shoulders to cry on, would be much appreciated.


What color LED do you have? Compare that with manual. If you do not have the manual, download it.

Removing the hard drive would be the last option. Search for the unbrick/debrick guide on this forum and that will tell you how to remove the drive, recover the files and re-install the OS.

Hi Shabuboy,

Thanks for the response. The light is a steady green which suggests everything is ok, but even when pressing the reset button, it doesn’t go blue and then back to green…it just stays green.

1 Like

Green means the cable is connected and it has an IP, either via static or DHCP server.

Try this: Unplug the ethernet cable on MBL, color should change and check your router’s DHCP lease/client table/list. Plug it again and see if there is a new device listed.

If no luck, try a switch, so you will have:
MBL connected to a switch
Switch connected to the router

Make sure you do the reset EXACTLY correct. Read the manual for the exact amount of time to depress the button.

Hi wdlive, I’m holding it for 4 seconds as per the manual, and there is no difference in the colour being displayed by the front LED.

Hi Shabuboy, apologies - when I mentioned the light was a steady green, I was referring to the LED on the front of the device. The LAN connection lights are: steady green and the activity light flashes every couple of seconds.

login to your router UI. Look for the IP address of the MBL in the router’s DHCP table. Then type the IP address into browser.

Tried that tonight wdlive76 - no dice. Still not able to connect. I have the device plugged directly into the ethernet port of my macbook pro…it’s not showing up on the list of devices on the router UI, but not showing up in the mac finder…


Hi Kev,
I have the exact same problem. No way to access the MBL and no way to reset. I have tried different routers, connecting directly to PC, nothing works. The harddrive is working and after connecting it with SATA cable to PC, I can access the files. Still no way to get it to work through the network.Hope some one has an answer, as I am close to buying a new case and using the drive as external HD.

Hi Gerwin, thanks for your response. I was thinking of stripping the HDD out of the case and installing it via a SATA cable. How easy was it for you?


I extracted my HDD from the My Book Live and mounted it in a SATA cradle. When I plug this into my Mac USB port, it recognises the drive, but tells me it needs to be formatted. Same when I try to connect it to a PC, it’s recognised but then the PC asks to format it. :sob: