Unable to register my MyCloud

I can’t register to http://files.mycloud.com/setup

After I click to register I’m getting message:
"This device has been already set up"

But it isn’t! Never registered this device, just plugged it lately. So, without username and password I can’t even login to administration panel.

Already tried to “hard” reset the device by holding the reset button for 4 secs. After reset it behave just like before, like nothing really happend by resetting it. How am I supposed to do anything with it? If I would need an another drive I would buy another drive, not a cloud one!

It is not clear what are attempting to do. Are you trying to configure the My Cloud? Or are you trying to access the My Cloud remotely?

To configure the My Cloud for first use or to modify existing settings, add/remove Users, add/remove Shares one typically accesses the WD My Cloud Dashboard (http://wdmycloud) with their web browser while on the same local network as the My Cloud.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=10420

It is through the WD My Cloud Dashboard one configures both the My Cloud and Users for Remote Access. If you have not already done so you should take some time and read through the My Cloud User Manual (http://www.wdc.com/wdproducts/library/?id=439&type=25) which explains how to setup, configure and use the My Cloud. Or once logged into the Dashboard see the Dashboard embedded Help contents for general steps on how to configure the My Cloud and its features/options.

Did your unit come in a sealed (shrink wrapped) box? Or was it a ‘customer return’?

Even if it’s a customer return, you should still be able to register it.

And you don’t NEED to create an account with WD, or use their automated setup to set the device up. Once you have reset the device (do a 40-second reset by unplugging the power, press and hold the reset button, apply power, wait 40 seconds, then release the reset button), it should clear the admin name and password, and revert to ‘admin’ with no password required. this should allow you to access the Dashboard, where you can set up everything on the device. When you get to the point where it asks you to set up an account with WD, hit ‘cancel’, and it will advance to the next stage of setup. You can create an account later.

For the rest of the setup, see the User Manual, skipping past the initial ‘automated setup’ section to the chapters based on the Dashboard.

Yeah, I’m trying to configure the device.

The only things I’ve already did, was unboxing it, pluging-in the power and connecting it to the router.

I can see the device under the network, but I’m not able to login to configuration panel (via http://wdmycloud or by just typing the IP address). Was trying to type in login admin and blank password but w/o effects, because I’m getting the message: “Only users with administation rights are allowed”.

Did your unit come in a sealed (shrink wrapped) box? Or was it a ‘customer return’?

Nope, it’s not a return, and the box was fine.

I’ll try the 40 sec reset and inform you if it helped.

40 sec reset solved the problem. Thanks!