Unable to play video remotely using mobile app

I have no problem playing video files when I am connected to my home wifi. When I am remote(LTE) I cannot play exact same files that I was able to play while connected to my home wifi network.
Any help would be appreciated.

Using which mobile app on what mobile OS? What is the media file format (mp4, mov, avi, mkv, etc.)

If using Android the app may prompt the user to choose an app to play the media file. If this is the case one needs an app that supports the media format one is attempting to play.

I am using my iPhone and iPad mini with LTE.
The mobile app I am referring to is WD My Cloud.
File format: MP4
Codec: h.264



What does “not play” mean?
Does it mean that you select the file and it continues to buffer but never play? or does it time out?

I can navigate to the folders and see the files . When I click on the thumb nail, app tries to play but displays an error message(unable to play this media file) immediately.

I just tried with MP3 files and have same issue. So, it is not just video files that I am having issue.

Do I need to setup port routing on my router to get the MyCloud app to work using cellular network?


Have you tried this solution already?

  • open mobile app
  • remove the my cloud device
  • close the mobile app
  • uninstall the mobile app
  • reboot phone
  • install app
  • add My Cloud by logging into MyCloud.com account (not the local add)

I have done that a few times already but thanks for your idea.
I just tried picture files(jpg and png) and they are working fine over the cellular network.

So, can I assume that everyone here has no issues playing MP3 or MP4 files over the cellular network and I am the only one with the issue?

What has previously been written above that prompts you to ask this?

I have an iPhone and just tried playing an mp4 movie from my WD My Cloud using the MC app while on the cellular network, and it worked – but not without my having to solve some initial issues. I hardly ever had done this, but just this past month we increased our data plan a little so now it makes it more likely to use it for limited streaming from cellular in certain instances.

Since I have always had the MC app setup to use wi-fi only. the app gave me the opportunity to select both wi-fi and/or cellular once I tried to stream via cellular. I also clicked on the notice for the app to warn me if I was on cellular if I started to stream media. If you don’t have these two settings right, you will likely have a problem as I did.

So, now when I clicked on the app to stream an mp4, the app warned it was on cellular, I could choose to continue or cancel. When I chose continue, the video started playing.

If you don’t get the opportunity from the app to make the changes to the settings as I did, then un-install and re-install the MC app. The questions to change the setting will appear as the app boots up first time, so select wi-fi and cellular and then go down further into the Setting options and select app to warn you if on cellular. As I said, that was all I needed to do as well as check other important settings that might have been changed from what I had set; none appeared changed…

Problem solved!

I called the support and got the problem resolved.
Short story: Download the firmware from the website and install it manually.

Long story: I was hung up and got disconnected when I called the support. At the end, I was able to speak to a level 2 person. While waiting for be transferred to level 2, my device decided it was the best time to go offline on its own. :frowning: I had to power down the unit by unplugging the power unit.

After I got connected to level 2, his first question was my internet up/download speed. My speed is at 50Mbps+ for both down and upload which is good enough to do streaming. He then checked various other things and noticed that my cloud setting was turned off. I know I did not change this setting. In fact, the default value is ON. I guess it got changed when I hard reset the power. In the middle of all this, my unit decided to go offline one more time. :frowning:
Unplugged the power to recycle the unit. This time, it decided to do consistency check for 20 minutes.
Level 2 support person suggested that we install the fresh copy of the firmware and said perhaps the unit is damaged if it still does not work.

After getting off the phone and waiting for the unit to come back online, I was able to install the fresh copy of the firmware and I was able to stream my media files!


Thanks for the feedback. Hope it continues to work well.