"Unable to play the selected file" using a 3TB HD via WDTV LIVE


I have been facing a strange issue since I installed the latest firmware (1.05.04 firmware) on my WDTV Live (WDBAAN0000NBK ) that fixed the larger that 2TB HD issue. 

I have two WD Hard drives connected to my WDTV Live, one is a WD My Book Essential 3TB (USB 2.0&3.0), and the other an older WD Essential Edition 2.0 1TB Hard Drive (WD10000H1U-00) 

My WDTV Live is connected to the network via a Cisco Wireless Router (Linksys E3000) which is connected to a DLINK (DGS-1005D) Gigabit Ethernet.

The issue that I am facing involves me copy video files (.mkv, .avi) from my laptop (Windows 7)  to my WDTV live via the network onto the WD 3TB HD.

Once the files have been successful copied on the 3TB HD that is connected to the WDTV Live, and I want to naturally view them on the TV,  that’s when the WDTV Live prompts the message "Unable to play the selected file, Please see the User …)

When I try to copy those files back to my laptop, those same files that worked before the transfer, don’t work anymore with any video player and seem to have gotten corrupted or damaged.

Now, when I copy the same original video files on to the WD 1TB HD, it works without any issues.

I have been trying to search the WD community to find out if anyone else may have a similar related issue that I am experiencing, but didn’t find any posts regarding this.

I really looked forward to using the 3TB Drive with the WD TV Live.

I hope the information I supplied is enough to give you an idea of my setup and whether there is a fix or a work around that help me with my issue



hi there 

me I am having also via usb 3tb book

there are no problems with any mkv,iso,ts or any such files

soft - the newest [sadly :)] 

maybe you have copied “icons/shortcuts” and not the 'files" - such a guess

pls revert with closer details and we shall solve it out as it works for me fine.




edit : pls plug in your 3tb book to direcly via usb to your laptop/pc [which is linked to the net] and pass check of update for “3tb book” … then check again and revet here back to say if that worked. 

Hi There,

Thanks for attempting to help me with my issue.

The files I copied aren’t “icons/shortcuts” :slight_smile: , they are the actual files (1GB, etc…). 

I am glad it works on your end

How do you transfer you files to the 3TB HD? Do you transfer them through the network and onto the 3TB via the WDTVLIVE.

I am not sure how to provide a better description then i already did.

I have upgraded the firmware of the WD 3TB HD to the latest available release, but it didnt fix anything.

Kind Regards

Apex Seeker