Unable to play file, MKV+WHS 2011


I’ve got some weird problems when trying to play mkv-files(not all though) from a network share on a WHS 2011 machine.

The same file plays fine when I share it from my Win7-machine.

It also plays perfectly fine from an USB stick.

If thats not weird enough it plays ok, even from the network share on WHS2011, when I run the file through “AVI mux gui”.

Any ideas on why this happens and/or how I can fix it? And with fix it I don’t mean to reencode every “broken” file manually…

Did you tried updating to the latest firmware?

Yeah, I’ve tried with the latest, 1.09.10 and 1.04.12. None of them works. At least with the latest I get an error. With the earlier releases the box “hangs” and refuses to play any file until I reboot it.

After having checked around the net today I’ve created a bat-file to which I can drag&drop files which fixes them.

The important line is this one:

“d:\Program Files (x86)\MKVtoolnix\mkvmerge.exe” -o “%~dpn1_fix.mkv” --engage keep_bitstream_ar_info -A -S --compression -1:none “%1” -D -S --compression -1:none “%1” -A -D --compression -1:none “%1”

So I guess my problem its because of this “header compression” or whatever it’s called. I still can’t understand why the files works when shared from a win7 or played from a usb stick though even before I fix them with mkvmerge…

MMh, the header compression bug should have been fixed several firmwares ago…