Unable to play an MKV file


#1

Hi everyone. I just received my WD TV Live HD (Model #WDBAAN0000NBK-NESN) and I’ve played a couple mkv files fine, but I have one file which will NOT play. Every time I try, I get a message that says the file is not a supported file type… I can’t find anything that would make it NOT supported… Any ideas?


#2

Welcome to the forums.

MKV is only a container – you can put a whole lot of ■■■■ into such a container.  How did you encode the file?  What audio and video codecs did you use?  (Not all are supported).

For best results, use Handbrake on your original (but set the output to MKV) with the High Profile preset.


#3

I didn’t encode the file. I believe its an h.264 file with FLAC audio… if Im reading the information correctly… I will try to use Handbrake. Its a LARGE file, (5gig ish) so it’ll have to wait until morning to test


#4

If it’s not your file check it with Mediainfo and post the results here so we might see what could be wrong with it.


#5

Format : Matroska File

size : 4.94 GiB

Duration : 1h 51mn

Overall bit rate : 6 333 Kbps

Encoded date : UTC 2010-05-28 17:46:33

Writing application : mkvmerge v3.0.0 (‘Hang up your Hang-Ups’) built on Jan 29 2010 23:27:24

Writing library : libebml v0.7.8 + libmatroska v0.8.1

Cover : Yes / Yes / Yes / Yes / Yes

Video ID : 1 Format : AVC

Format/Info : Advanced Video Codec

Format profile : High@L5.0 Format settings,

CABAC : Yes

Format settings,

ReFrames : 8 frames

Muxing mode : Container profile=Unknown@5.0 Codec ID : V_MPEG4/ISO/AVC

Duration : 1h 51mn

Width : 1 920 pixels

Height : 1 080 pixels

Display aspect ratio : 16:9

Frame rate : 23.976 fps

Color space : YUV

Chroma subsampling : 4:2:0

Bit depth : 8 bits

Scan type : Progressive Writing library : x264 core 96 r1613M 81e75e9

Encoding settings : cabac=1 / ref=8 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=9 / psy=1 / fade_compensate=0.00 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=crf / mbtree=1 / crf=16.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00

Audio ID : 2

Format : FLAC

Format/Info : Free Lossless Audio Codec

Codec ID : A_FLAC

Duration : 1h 51mn

Bit rate mode : Variable Channel(s) : 7 channels

Sampling rate : 48.0 KHz

Bit depth : 16 bits

Writing library : libFLAC 1.2.1 (UTC 2007-09-17)

Language : Japanese

Text ID : 3 Format : **bleep** Codec ID : S_TEXT/**bleep**

Codec ID/Info : Advanced Sub Station Alpha

Title : English Subtitles

Language : English


#6

hopefully that fixes the formatting…


#7

I’m pretty sure FLAC isn’t supported.

If that’s all it is, don’t bother with Handbrake.  If you are comfortable with command line interface, you can just use ffmpeg itself and re-encode the audio (a whole lot faster than re-encoding both the video and audio with Handbrake).

Command line will be something like

ffmpeg -i myfile.mkv -acodec  AAC newfile.mkv

(You could also use AC3 if you so desire).  Shouldn’t take more than a few minutes to re-encode the audio.


#8

I tried to use ffmpeg, and I get a Unknown encoder ‘AC3’ (or AAC) error message :\

thanks again for trying to help!


#9

Then something is wrong with your installation of ffmpeg, because AAC and AC3 are standard codecs supplied.  Either you didn’t install all the libraries or you got it from some place where it’s incomplete.

It’s not easy to actually download it because the developers are kind of shy about it (not wanting to incur the wrath of the Powers that Be).  Try this site:

http://www.ffmpeg.org/download.html

or here

http://www.videohelp.com/tools/ffmpeg

after first uninstalling what you have.

(I tested that command line on several of my machines and it works just fine).


#10

I downloaded the file you linked, extracted it, and put in the same command line, but this time, new error message! Same message with both AAC and AC3

Error while opening encoder for output stream #0.1 - maybe incorrect parameters such as bit_rate, rate, width or height


#11

While you shouldn’t have to do this, try:

ffmpeg -i inputfile.mkv -acodec aac -sameq testout.mkv

(or AC3, either way). 


#12

same result as last time :\

As a note, every time i use aac, i have to add -strict experimental to the command line heh

this file is cursed!


#13

Um I don’t think it’s the file per se – still think your computer/ffmpeg is wonky.

But try it on something else – pick ANY other MKV file or AVI or anything, really  (something from the web, let’s say) and see if you can do the audio transcription.  If that doesn’t work with the same error then it’s not the file (because the errors you are getting don’t sound like a file issue).

In the meantime you can indeed run your file through Handbrake (overkill for the video but at least you’ll get something usable).  If worse comes to worst you can always demux the Handbrake file audio and mux it with the original video using tsMuxer and mkvmerge (a LONG way to go to get the audio right, but it will work).


#14

Hey Crimson,

If the ffmpeg CLI is giving you headaches, try HeartWare’s Audio Converter.

http://audioconverter.heartware.dk/Tutorial/

There’s a section in the GUI specifically for converting multi-channel FLAC to AC3.

If it needs specific codecs to convert FLAC, it has links to download them and point the GUI to them once you’ve installed them.

It’ll leave the video in the MKV alone and just process the audio track, outputting a new MKV with the converted audio.

I’ve been able to convert DTS and AAC5.1 tracks to AC3 with no issues.  Good luck!  ;)


#15

mkelley wrote:

Um I don’t think it’s the file per se – still think your computer/ffmpeg is wonky.

 

But try it on something else – pick ANY other MKV file or AVI or anything, really  (something from the web, let’s say) and see if you can do the audio transcription.  If that doesn’t work with the same error then it’s not the file (because the errors you are getting don’t sound like a file issue).

 

In the meantime you can indeed run your file through Handbrake (overkill for the video but at least you’ll get something usable).  If worse comes to worst you can always demux the Handbrake file audio and mux it with the original video using tsMuxer and mkvmerge (a LONG way to go to get the audio right, but it will work).

Well, this may be a start. tried it on ANOTHER file, got a different error code 'Encoder (codex id 0) not found for output stream #0.2

where should the ffmpeg file be located? since i think that means it cant find the codec instructions…

Pixelpower - I got this as an error message “Skipping conversion - none of the audio tracks can be converted or the conversion has been disabled”


#16

Yeah, ffmpeg is not installed properly.

Do you have ffmpeg.exe in your WIndows directory?  (Root\windows).  Quite honestly, I installed it so many months ago I can’t even remember how I did it, but it wasn’t too difficult.

Here’s where I got my own build of ffmpeg (although when I got it the 64bit version was fine and now it’s not):

http://ffmpeg.arrozcru.org/autobuilds/


#17

mkelley wrote:

Yeah, ffmpeg is not installed properly.

 

Do you have ffmpeg.exe in your WIndows directory?  (Root\windows).  Quite honestly, I installed it so many months ago I can’t even remember how I did it, but it wasn’t too difficult.

 

Here’s where I got my own build of ffmpeg (although when I got it the 64bit version was fine and now it’s not):

 

http://ffmpeg.arrozcru.org/autobuilds/

I downloaded the 7z file, extracted into C:\windows, and repeated the process. I got the Error while opening encoder for output stream #0.1 - maybe incorrect parameters such as bit_rate, rate, width or height error again…

I havent INSTALLED anything, at least not with an autoinstaller… All Ive done is extract the files


#18

Well, I’m not the one to be asking about ffmpeg installation (I know how to use it, not to install it :>).

I’m sure there are support forums for it – you might try asking on one of those.  But there is definitely something wrong, somewhere (maybe it’s a permissions thing.  I don’t know).

It’s such an insanely useful tool to have working properly you might want to track it down (there hasn’t been anything I haven’t been able to fix with ffmpeg, including flash animation, so that it will play properly on the Live).