Unable to open shares with specific user permissions in Finder

Hey there,

I have been having this issue since the original firmware upgrade to v4.00… and had hoped it would be addressed in the recent update, but apparently not. I’ve not managed to find anyone else having this issue, so might just be something I am missing - but it worked before?

I am unable to open shares from within Finder that have specific user permissions, receiving the error that the share cannot be found, though it is fully functional from the desktop app.

*Turns out, since customising the name of my WD My Cloud, I also cannot access the public folders from Finder.

Any insight would be much appreciated.

Thanks in advance!

have you tried manually mapping the shares using SMB and connecting as a registered user as opposed to using Finder?


Thanks for your response…

Is this through the ‘Connect to Server’?

I have tried AFP and SMB - both to no avail.

My housemates who also have their own shares say it works fine on their Windows machine… maybe its something to do with Yosemite afterall. Hopefully there will be a fix soon as Yosemite was released to the public a few days ago!

I am not an apple person so I could be wrong but the icon you are connecting to is different then the other so is it possiable you only renamed the media server and you are trying to connect to the DLNA server which dosn’t support users and passwords

you also have a wdmycloud icon. what happens with this?

Thanks for your response…

I believe the ‘mac-like’ icon is just symbolising that it recognised the device is ‘Apple friendly’, whereas through the ‘Connect to Server’, as previously recommended, I imagine its just going straight to connect and put the icons on later.

The wdmycloud icon is just a residule icon as I had literally renamed it moments before taking the screenshots, that icon is gone now.