Unable to obtain IP address

As you discovered, there are flavours for security+encryption :smiley:

There shouldn’t be, but…

Do you have latest firmware for USB wifi adapter? Your router has the latest firmware?

If you put your USB wifi adapter into a laptop, are you able to connect to your wifi?

My router is working there are a mac and a pc connected, and It has the latest firmware.

The usb adapter used with the wdtv is working properly, because It works (can connect and surf) if plugged in the notebook, It’s firmware is ok.

I really don’t know what can I try more, I joined here to check if other people are having my issue too.

Try this:   Set your router to BROADCAST the SSID. 

That way the WDTV will know automatically what the security/encryption type is.   Then all you have to provide is the key.

Example, my access points are using WPA2 Personal / AES.    When I select that SSID from the list, it immediately asks me for my password because it already knows what mode it needs to use.

@TonyPh12345

Already tried with but no luck, as I’ve already told in previous posts, It just doesn’t work if there is security/encryption.

I know It’s strange… But I’m in that situation.

So when you set it to BROADCAST, it still asks you for what type of security to use?  

I’ve had no issues at all.   I used to use Non-Broadcast G with WEP 128Bit, and didn’t have a problem with THAT other than how tiring it was to key in a 26-character key…  Now I’m  using WPA2 + AES and have no issues.   There’s something odd about setup, undoubtedly, but who knows what it could be…

Really I don’t know what happen to my wdtv :slight_smile:

I’m starting thinking the wifi adapter is not fully compatible or something like that.

NKjoep wrote:

Really I don’t know what happen to my wdtv :slight_smile:

 

I’m starting thinking the wifi adapter is not fully compatible or something like that.

That *IS* a possibility.   The other possibility, though remote, is a hardware failure.   My FiOS router quite a while back decided it did not know how to do WPA encryption any more…  It would say that it was set for WPA, but was acting as if it was OPEN.

definitely the problem lies in recognizing the correct type of encryption. At first I could connect without problems, but  suddenly could not get the IP anymore. Then checked that the SSID manually registering and choosing the type of encryption would , WDTV gets the IP.  It seems that incorrect information is recorded in its memory.

I hope that WD techincal suport solves this problem quickly.

I’m having the same problem.

Bought it in July 2010 and worked fine.  Stopped successfully connecting after 2-3 FW updates.  If you goto Network Settings>Network Setup>Automatic> … locate my WiFi network (which has a red circle X on it) and click on it > Wireless … it will always connect.

One thing I noticed is before the bootup took minutes with the factory FW.  Now the bootup is <1min.  Maybe they reduced the time waiting for the linkup to happen and it’s timing out too quickly??  I use encrypted WEP.  I used to use ACL MAC address filtering, but I turned that off thinking this was the issue.

For now I’m just going thru this process on every startup hoping a new FW update will fix it.


WDTV Live Plus 1.04.10B, EVAW111 Netgear Wireless N USB, Netgear Wireless N Gigabit Router WNR3500