Unable to login to My Cloud Dashboard

We are actually looking into this.  However, for some of the users we found that resetting the device with the power off fixed it. 

If some of you have deleted the Admin account this could happen to you.  You will need to reset the My Cloud with the power off. 

  1. Pull the power plug.
  2. At the same time as you plug power into the WD My Cloud device, press the Reset button and hold for about 40 seconds. The device undergoes a system restore and powers back on.

Note: this is found on page 120 of the Users Manual.

If this doesn’t work for you, then contact Tech Support for further help. I would recommend calling in. They should know what to do next.

Contact WD
http://support.wdc.com/country/index.asp?lang=en

Does the reset cause the data on the drive to be lost? My cloud worked fine for a couple weeks and this just started. I know my user and password. I unplugged the unit and now when I try to get to the dashboard the web page won’t load on any device or browser

Before you reset, you are sure the IP address didn’t change, right?

If you are sure, the answer to your question is no: a system only reset will only delete your users and leave you with the default admin username, and a blank password. All your content will be preserved.

Thanks Etupes, it was an address change problem. After unplugging and correcting address link it works as normal… We’ll see how long it stays working!

Worked for me.Thanks!

This absolutaly didn’t work for me. I tried everything above, nothing. I still can’t get into Dashboard. 

I was promised that WD My Cloud was an easy to use, simple device. But I had nothing but trouble with it.

I don’t like the way it works, I don’t like the way it looks. 

Mine is going back to the store, you have got to get your product working WD.

2 Likes

Purchased WD My Cloud 2TB yesterday and within 24hours I was unable to login to my Dashboard.  Will the issue get fixed soon or should I return it to the store?

Info for other users with this problem and for WD people trying to find a fix. I think I had the problem described here, and simply restarting the WD My Cloud seems to have fixed it.

Everything seemed to be working fine, but today I found when logging in to the dashboard I was almost immediately logged out. Simply restarting the My Cloud seems to have fixed the problem. I can now log in. The four user accounts I had setup all seem to be working OK.

Firmware v04.00.01-623

Could you translate this into layman’s language?  Sounds like you solved the problem, but I have no idea what a lot of these terms mean.

Hi,

I have the opposite problem.

I can’t figure out how to set a password for the UI dashboard.

I can access the dashboard from any device in my LAN but I’d like to set a password so inquistive kids don’t mess things up.

Thanks.

Same problem here:

  1. Bought WD MyCloud 4 TB

  2. Plugged it into router.

  3. Logged in through web browser. (It was slow for some reason, too slow for what you would expect from a device like this!)

  4. Made 3 users, including myself as an admin (but under a different name, not “admin”). Added static address.

  5. Added password for my admin acount, just to test it.

  6. Deleted password for my admin account, just to test delete feature. Worked ok.

  7. Saw that there was update/upgrade available and clicked on it.

  8. It took ages to update. In the end there was something like “Update not successful, try again later”. So I did try again later… No success. The only thing that changed is that the LED is now white-ish, that is white and a bit purple or pink (not red).

  9. Had to power it off (unplug it) manually.

  10. Plugged it in. Logged in through web brower. Painfully slow, not opening a page, just starts. Router sees it at the same static address and I see the page trying to pen, but stucks somewhere. After several refreshes and after using 4 different browsers on the same machine, and after using different PC and again 4 different browsers, I finally got the MyCloud page.

  11. I logged in through WD My Cloud Windows software. Needed to try 3-4 times. (There was no password, it just didn’t want to log in, it took ages trying.)

  12. Then I couldn’t log in any more. Nothing happened, I just couldn’t log in any more: the mani page would take ages to load and would then say something like “this page cannot be accessed”; Widnows My Cloud app says “there is no device”, or something similar. In another words, WD MyCloud NAS cannot be seen in the network. I checked the network, cables, router - everything was working fine, except MyCloud that was not working fine.

  13. LED was randomly blue, then whitish (a bit pink), then blue after restart, or white after restart - but not white for a couple of minutes, just white all teh time.

  14. I did this “hard reset”, I pressed reset button for about a minute and saw the LED blinking and then going white. OK, it’s resetting, or something of that sort, that’s what the manual says…

  15. LED is stil whitish (with pink) for ages, say for 30 minutes. Too long to update or upgrade or reset, I thought, especially because there are no files on the device.

  16. After an hour I reset it again.

  17. The same process… It took long…

  18. After several hours of frustration it allowed me to log in again (no password). Interestingly enough, when I log in through Windows app, I see 3 users that I created before I resetted MyCloud, but when I access it through web browser - I see only one (admin) user. I checked several times, because I couldn’t believe my eyes.

  19. So I stopped MyCloud and unplugged both cables from it. I powered it off. I powered off both computers, too.

  20. I turned on 2 computers and I turned on MyCloud. No changes to previous state: LED is white-ish for 15 minutes, sometimes 30 or more, then becomes blue, but the webpage won’t open, it gets stuck and shows something like “opening…” or “gathering information” or “loading” or “reading configuration information”. I see the page in the background, but I can’t click on it because it’s “processing”, “accessing” (or something, whatever).

  21. Finally the web page opens, in my N-th try. It asks me to agree with the WD End User License Agreement. I tick the box, scroll the agreement, click “Continue”, and get the ridiculous message “Problem confirming acceptance of license agreement.”, written in red letters. What the heck? I tried several times, on 2 computers, using 4 different browsers - that’s 8 in total, and I tried several times. No luck, every time and on every computer - same message, there is a problem in confirming acceptance of linecse agreement. How is this possibe? Frustrated through the roof I went to sleep.

  22. I turned off everything over night and started everything from scratch the next day.

  23. New surprise was coming: now not only web interface shows (again) “Problem confirming acceptance of license agreement.” (and there is nothing I can do about it and can’t go past that step), now Windows My Cloud software says either “Remote access to your network device is currently unavailable.”, or asks me to connect using login “admin” (no other choices!) and password that I never set up.

  24. I tried no password, then I trid password I put in at the early stages of my frustration (the one I deleted at the very same early ages and confirmed several times that password didn’t exist any more!!!), then I tried various random passwords (i.e. password, Password, sa, SA, admin), and none of them worked. I just can’t login to device!

  25. After another hour of frustration and after almost finishing this writing, I tried again through web and through Windows WD My Cloud software.
    Web interface says “Problem confirming acceptance of license agreement.” 
    Windows app started opening the console and I think I can see all 3 users (that I presumed would be deleted while hard resetting and that I couldn’t see when I logged in through web interface!), but then it said “Remote access to your network device is currently unavailable.”

“Remote access to your network device is currently unavailable.” - I clicked ok, and it opened the My Cloud panel. What the …? No password problem any more? How? Why?

Web access is still stuck at “Choose your language” and “Problem confirming acceptance of license agreement.” which doesn’t allow me to go past that step.

Why is all this happening? Shouldn’t this be a simple process that just WORKS?

My next steps?

a) Return the product and buy a similar product of a different company.

b) Share my experience and links to similar experiences of other people, so that people like you and I know and can avoid this whole frustration and potential problems and loss that this unreliable product can cause.

Seriously, how hard is it to make Linux based NAS device? How hard is it in 2015?!?

Please, someone from WD explain why is this happening and how reliable this WD MyCloud actually is.

If it’s just a test product - please let us know, so that we can save ourselves from trouble.

(I understand “License agreement” serves to protect companies from almost ANY liability. Therefore please tell us if this product is mature for market release, or is ths just an experimenting on live audience/users.)

So frustrated with this device…

2 Likes

UPDATE:

I was contacted buy WD support. Their email is quoted below, at the end of this post.

I didn’t bother going that way, and here is why: I am an experienced IT person and this device should work OUT OF THE BOX, and should work FOR EVERY USER, and should work WITHOUT WD IT SUPPORT, and should work WITHOUT WASTING MY TIME on whatever WD support will ask me to do with faulty WD MyCloud 4 TB drive.

In reality, there was nothing they could have told me to do that I haven’t already tried (and tried probably several times, until I got frustrated and gave up with no result besides me wasting time and money and ruining my mood for nothing).

Seriously irritating situation…

Anyway, instead of waiting for WD phone call that would walk me through all the steps already described in their User Guide and all the steps I already tried, and, actually, all the steps that exist, I simply went to the shop to return the product and get my money back.

Alas, last minute I decided to swap it for another (same) device. So I returned the new and faulty one and got new and what I was hoping would be working one. Same shop, same device.

This second one was working, out of the box. Good, I thought. I tried copying files, creating another user, etc. All good so far.

Then problems started. At first the device started bogging down, slowing, random behaviour. My network works perfectly well, by the way, thanks for asking. Gigabit network, everything works just fine. Except for this WD MyCloud 4 TB drive.

Let me describe the problem here…

First, the device randomly gets disconnected, or, more precise, inaccessible. All of a sudden - it’s gone. No UI, not responding, just gone. However, I can see it in LAN, it still has its IP (untill I had to turn off MyCloud). So it just gets non-responsive, be it in home LAN, or through mobile app. And yes, my internet works fine at the same time, I can access internet. I just can’t access MyCloud drive that’s sitting next to me and that I could access 10 seconds ago. Just like that.

Another problem is that if WD My Cloud is started (turned on) with a USB HDD plugged into it (and, yes, it was WD My Book Essential pluged in, 3 TB drive), WD My Cloud is inaccessible again. No way I can access it, be it UI through LAN, or vua mobile app.

I tried Firefox, Chrome, Opera, I even tried MS Explorer. Nothing. Zero result.

Then I googled and found out that I’m not the only one facing this issue. I lot of people have the same issue:

http://community.wd.com/t5/WD-My-Cloud/bd-p/mycloud

For example:
http://community.wd.com/t5/WD-My-Cloud/When-are-we-going-to-get-a-firmware-update-that-fixes-major/td-p/859260
http://community.wd.com/t5/WD-My-Cloud/my-cloud-doesn-t-give-any-response/td-p/860791

http://community.wd.com/t5/WD-My-Cloud/WD-MYCLOUD-cant-be-seen/td-p/860704

http://community.wd.com/t5/WD-My-Cloud/MyCloud-Dashboard-Login-and-Remote-Login-not-working/td-p/860596

http://community.wd.com/t5/WD-My-Cloud/open-vulnerabilities-in-WD-My-Cloud-Feb-2015-Firmware/td-p/859330

All this can be summarised in the following quote from the following thread:

When are we going to get a firmware update that fixes major issues

EXACTLY… fix issues like nework disconnections that are affecting a large number of people.

Dasboard access gong away, 

Firware updates getting stuck

Remote access issues

So, to end this post, it’s really a terrible user experience because WD My Cloud drive either does not work, or it works IF and WHEN it wants to work, exercising totally unpredictable behaviour. Maybe it was just a coincidence that I bought TWO drives with (different) problems, but, really, this shoudl be something that just works without glitches. Seriously! It’s a Linux server, it should work just fine once it’s installed and set up properly!!!

Oh, maybe that’s the problem: “once setup properly”!
Could it really be that someone in WD department had poor knowledge about this technology or about Linux, and they released this and are constantly having problems for almost 2 years now, but still no resolution in sight?

Sigh… This time I’ll go through the process with WD support and see what happens. Whatever happens - I’ll make a note here, so that we know. After all, big companies SHOULD have BIG responsibilities and not just get small users shafted all the time.
If they can’t make this NAS work - then they shouldn’t market it and sell it at all, period! And if they know how to make it work as it should - they they should!

Will let everyone know how this ended, once it ends.

Cheers everyone!

p.s. Here is the initial email from WD support. Last time I returned the (new and faulty) drive and got another (new and faulty) drive, not knowing it would be yet another type of faultiness. Let’s see what WD support will do this time to resolve the issue.

p.p.s. Once again, this thing should just work out of the box, just work, with no glitches, problems, down time, etc. It should just work!

Dear [my name was here],

 

Thank you for contacting Western Digital Customer Service and Support.  My name is [Deleted - Trancer].

 

I do apologize for the inconvenience. I will like to contact you and troubleshoot the issue that you are encountering. Can you please provide me with a contact number, your name and a convenient time frame so we can schedule a call back accordingly. 

 

Thank you.

 

If you have any further questions, please reply to this email and we will be happy to assist you further.

 

 

Sincerely,
[Deleted - Trancer]
Western Digital Service and Support
http://support.wdc.com

2 Likes

Excellent. you described in great detail the scenarios. Yes, im also one of them who HAS THE EXACT SAME ISSUES with these drives…

I’m an IT admin myself and i know my stuff and this thing has given me the run around. Still no real solution available by WD except some crappy firmware updated that introduce more bugs then fix them!

Is it normal to see these log entries in /var/log/messages.

First the link up and link down messages!! NOTE that are no issues on my network or my routers. I have three of these drives and only this one shows the link up down messages. The network cable is NEW. All devices are plugged into the same switch… Note that however even though the below messages were there my drive did not get in its usual " gone from the nework" state and was still reahable in the morning.

Mar 1 23:28:55 Nas1 kernel: [13477.101904] PHY: comcerto-0:00 - Link is Up - 1000/Full
Mar 1 23:30:41 Nas1 kernel: [13583.111928] PHY: comcerto-0:00 - Link is Down
Mar 1 23:30:43 Nas1 kernel: [13585.112029] PHY: comcerto-0:00 - Link is Up - 1000/Full
Mar 1 23:31:07 Nas1 kernel: [13609.111912] PHY: comcerto-0:00 - Link is Down
Mar 1 23:31:10 Nas1 kernel: [13612.112111] PHY: comcerto-0:00 - Link is Up - 1000/Full
Mar 2 00:02:02 Nas1 rsyslogd: origin software=“rsyslogd” swVersion=“5.8.11” x-pid=“4419” x-info=" [http://www.rsyslog.com"] rsyslogd was HUPed

Secondly, what do these drives do around 3am that causes these messages about the RAID… Is it part of the system health check cron? I have the below messages on all my WD mycloud drives…

Mar 2 03:05:02 Nas1 kernel: [26447.811801] EXT4-fs (sda4): re-mounted. Opts: user_xattr,barrier=0,data=writeback,noinit_itable
Mar 2 03:05:02 Nas1 kernel: [26447.839949] md: md0 stopped.
Mar 2 03:05:04 Nas1 kernel: [26449.184464] md: cannot remove active disk sda1 from md1 …
Mar 2 03:05:04 Nas1 kernel: [26449.286051] md: cannot remove active disk sda2 from md1 …
Mar 2 03:05:05 Nas1 kernel: [26450.390666] EXT4-fs (sda4): re-mounted. Opts: user_xattr,barrier=0,data=writeback,noinit_itable,init_itable=10

Here are some screenshots, to illustrate how WD My Cloud can frustrate unsuspecting user.

I do hope good folks from WD will take notice and do something about it. For now, I bought two of these WD My Cloud … things … and the first one didn’t show UI after initial (automatic) firmware upgrade (and it even refused to accept the “I accept the user agreement” tick!) and became totally unusable the same day I bought it, while the second one worked well the first day (or the first time), but second time I tried to use it (i.e. second time it booted) it just started popping error after error after error.

As explained in my previous post (on page 6), WD My Cloud:

  • randomly disconnects from local network,

  • randomly does or doesn’t recognise WD My Book Essential USB HDD,

  • randomly deletes users,

  • randomly shows only one out of two partitions on an attached USB drive (it it detects drive at all!),

  • randomly shows “no USB drive” in upper right corner, even though USB drive IS connected, and at the same time shows drive among folders,

  • randomly shows there is USB drive atached (notofication in upper right corner), but does not show that drive among folders at all and, therefore, attached USB drive is inaccessible,

  • randomly shows or doesn’t show WD My Cloud capacity,

  • randomly refuses to reboot and stays in that state forever, sometimes popping up messages (incredible how many different messages it can come up with, while not being able to properly turn off or reboot!),

  • and so on, and so forth.

Incredible how many errors this NEW WD My Cloud can come up with! And imagine going on a holiday, or leaving it at work, or any other scenario where you need the drive (or, alas, your own cloud service, which is why you bought it in the first place!), and this device simply DOES NOT WORK. Imagine the frustration!

This device may not be totally useless, but from what I’ve seen so far, it can be pretty unreliable and is more like a game of poker or some crazy gambling, where you never know if WD My Cloud will work next time you need it.

I really struggle to understand how WD people managed to make a Linux based machine that DOES NOT WORK. Seriously!
I remember Linux servers working for years in LAN and WAN networks, having many concurrent users on our experimental network literally 10-15 years ago, working on poor machines, with no interruption for months and even years, and even then it was usually only power problems and not Linux/server problems (i.e. power cut offs in the area, so the machine would simply restars after power was on again).

How, on Earth, does WD come with this solution to the market? In all seriousness, with this bad experience I had so far, it’s more like My Cloud was a high school experimental project, not a mature product ready for worldwide market.

Sigh…

Here are some screenshots… Hopefully good WD people see this and do something about it.

WD MyCloud - problem - Users UNKNOWN - 2015-03-11.jpeg WD MyCloud - problem - Users UNKNOWN, add new user - 2015-03-12.jpeg

Hi guys, 

I had been suffering from the same problem (i.e. being repeatedly asked for my username and password, and it coming back with “invalid username of password” all the time, making it impossible to connect any new devices but only able to stream and copy/paste from/to my existing desktop). 

I rang WD now on their UK number and spoke to an advisor there who confidently said that I could either perform a Quick Reset or System Restore and neither would affect my system data, but just reset the usernames/passwords. He also said to try “admin” as the username and leave password empty. When that didn’t work, I opted to try a quick reset as follows:

With the cloud on, I inserted a paperclip into the reset button for exactly 6 seconds. I then removed the paperclip and checked -  the front light was flashing blue continuously on/off. He asked me to wait 5-10 minutes, took my case details and gave me his name so I could contact him back directly, and hung up. 

I waited 5-10 mins and found as early as 2 mins in, I was no longer being asked for username/password to login to the dashboard. The drive said “initializing” for about 5 mins, and eventually let me in. I am now able to access it on all my devices (I think the first time you add a new device it asks you for username and password, as I had not set either, I used “admin” as username and left the password blank). Everything seems to work fine. 

Just thought this may be of help  - the key thing here is that NONE of my data was lost in performing the Quick reset as I have described above, so I would suggest give it a try, if you haven’t already.

Thanks,

For anyone still having problems reseting the dashboard password for the EX4 I found a way that worked for me. I created a passoword through the dashboard and then also tried to create a username which threw up an error saying it couldn’t connect or something like that. Ever since that I was not able to log in to the dashboard through the admin username or the one I tried to create. I then, to try and do a factory reset, unplugged the device and then held down the reset button while pluggin in the unit and held it down for another 40 seconds. I also did the 4 second reset with the unit on and had no success when trying to log back in to the dashboard. It would keep throwing up the wrong username and password error. I tried those methods a few times then decided to try this one.

I shut the unit down by holding the power buttong for a few seconds. Once it was shut down I waited a couple minutes(probably doesnt matter how long you wait). I then, while holding down the reset button on the back of the unit, pressed the power button on the front of the EX4. I continued to hold down the reset button for the next 40 seconds. I then sat and watched the front of the unit. It booted up regularly to begin with but after a few minutes went into a rebooting process. Once it finished that I was able to go back in to the dashboard with just the admin username and no password. I am not sure if this will work for anyone else but hope it helps.

1 Like

Yes we, too, have encountered this problem.

Everything with the MyCloud was working fine for the first two months until 24th April when we had a power outage.

Once the power was restored, we rebooted everything in an orderly manner.

When we tried to access the MyCloud device, access failed. We tried every account/password combination but each one failed.

The manual should state that a UPS is required for this device, if the power outage is known to cause this type of problem.

regards

SeaCay

The only thing that I have found that solved this problem, for which I am sure has been mentioned in this thread, is a “Power On 40 Second Reboot”. See page 119-120 in the User Manual. Then clear your PC’s credentials and try again. All your data will stay intact.

I had bought my WD My CLOUD last month.  load everything from my buffalo hard drive into it.  Everything works well on iphone and ipad.  At home wifi or net work is fine.  Only until now i decide to log in from my office network to see some photo.  

It bring me to a blank page after logging.  After readying so many post, if i can’t access through remote, then this pcs of device is really useless then.

Anyone face the same problem?  Mobile and ipad works for the app but desktop don’t work?  Is reset the only option?