Unable to login to My Cloud Dashboard

I set up the device a few days ago and today see the same issue as planetmike. The user name and password are correct, but it keeps coming back to the login page until I unplug and then plug the power cable. I just turned off the password.

Hi Bill,

I can’t access my My Cloud Dashboard. I can login, but it bounces me back out after about a half of a second. Please tell me what I need to do.

: / Tod

I have the same problem. The user and password I have entered are correct but I am always redirected back to the login page. If anyone knows the root cause of this problem, please share.

Yes, same problem here. I get bounced and automatically redirected to the login page.

I am able to see files within my network. But I cannot access anything remotely.

It seems this issue is being replicated within a lot of users. 

What is WD Doing to resolve this issue?

We’ve passed this along for review. 

I also cannot login to my Dashboard. It logs me in for a split second. Please can someone let me know how to resolve this if possible? Many thanks!

Same problem with Login this morning. Purchased 2 days ago. No live support on Weekends. Not a Good start !

Same problem here. Tried to reset the password via SSH, did not  help. Can still access the shares, but not the Dashboard.


same problem. Cannot access dashboard.

firmware is up to date.

password is correct.

please advice how to proceed assoon as possible.


I have the exact same issue, unable to access the dashboard after updating firmware. I can log in and then it kicks me out and asks me to log back in again repeatedly. Additionally, my users are unable to access their shares. It keeps giving them an authentication error even though the username and passwords are correct, this includes my own.

I haven’t been able to create an username or password. I can’t even get to set up/ dashboard. There’s simply no connection between my Mac OS 10.8. and the WD MY CLOUD


I am having similar problems.  Bought my WD My Cloud less than a week ago.  Inital setup went smoothly, files were transfered seamlessly.  When I went out of town for a few days and returned to my home network, the Dashboard was unaccessible.  I log in, using my correct username and password, to find I am quickly reverted back to the login screen within seconds.  There is no displayed “invalid username or password,” so I know I am entering the correct information.

Disappointing I am having problems so soon with this software.  Hopefully this issue will be resolved soon.

1 Like

YES - this is problem…how to fix it?  WD?  Where are you guys?

ALSO - if it is an issue resolved through firmware update…PLEASE include info on how to update firmware when the dashboard is NOT available…  cuz - yeh, that would be helpful.

Possible fix.

I just did a firmware update and power cycle and got the same UI problem - endlessly asked for my password.

I ssh’d into the device and did

  passwd username

and re-entered the password.

Now it works fine.

I assume that the update to v4 firmware borks /etc/passwd- or /etc/shadow somehow, and so you’ll need to manually reset at least the admin user.


Oi WD would someone wake up & respond please. This is totally unacceptable & the lack of responses is truely poor & just further pushes me towards returning this as unusable.

I am using windows xp & chrome browser & once again can not access the dashboard, won’t connect through my mapped drives and on my last reset it removed all my additional accesses for phone/work pc etc so can’t access it anywhere except 1 single computer making it an expensive external hard drive which is not what i wanted. i’ve not had access to the dashboard & mapped drives of mine move than i have! I’m not techy but seriously considering just building my own.

1 Like

A followon to that - it looks like the *firmware update* to 4.xxxx zaps all passwords.

I was able to login via ssh because I did:

Turn on MyCloud for first time.

Setup with admin interface

ssh in - yay!

On my computer, do

  ssh-copy-id root@mycloud

to get my private key copied across.

*Then* update firmware, reboot, and so on.

I could still login as root because the firmware update didn’t bork the ssh keys.

Same boat as everyone else it seems. I bought this My Cloud on August 4th and have probably spent at least 10 solid hours trying to get it to work. The initial plug in and set up was a breeze. It was recognized, could map a drive, etc… but in another thread, I described my backup problems. I had to adjust a handful of services settings. Quite frankly, I am stunned the setup software doesn’t force the settings it deems necessary to run successfully. Any other setup/install program does that.

So once I got it going, it ran perfectly for one evening, backing up as I expected it. I checked in the morning to see the progress and there was a notification that it was partially backed up and more would be backed up later. Curious, I thought but I didn’t have time to look into it. 

I checked last night to see if it would have kicked itself off again only to find that Smartware is prompting for a login to access the drive. At least it was still seen by Smartware.

So I jumped into wdmycloud.local/UI/ without a problem. I could see everything, saw that there was data there from the previous night’s backup. I manually moved 8 files from my phone vie the My Cloud app and could see them on the drive but could not log in from Smartware to kick off backup.

When going through the tray, I saw there was a firmware update so like a dummy, I clicked it. When the update was complete, I could still see the drive in Smartware, still got prompted for credentials, but now access was blocked from the phone app, wdmycloud.local/UI/ could not be accessed, and the dashboard looked as if the drive was offline. I veryfied that it was plugged in and on but did not do anything to reset it. 

This morning, everything still says offline, though I am able to sucessfully ping the IP without any failures. 

This is frustrating beyond belief. I am technically literate enough to follow instructions, but I am no system or network admin and I can’t imagine someone without computer savvy trying to get this thing simply working, forget some of the fancy capability, I will be happy if I can get just basic backups to take place without my intervention.

I can’t believe how a large company like WD allows this product into the market. Obviously, this MyCloud release has many bugs which makes it unusable, but it’s more than that. The UI lacks simple features which would make it more user friendly, e.g. a status message or a pop up window saying what the program is doing, faster population of the UI with known values, etc etc.  Instead the user has to stare at the screen waiting and waiting for something to happen.  I know something is happening because I see the processes runing in Process Explorer…After a week of [Deleted] around with it I did a Full Restore. It took 28 hours for 800GB. In this moment I have my 2TB MyCloud with no data in it but I still have the same password issues  people are complaining about.  In my case,  I can create a user other than admin, but that user can’t sign on to the dashboard. Only admin can log in. When logging out of the dashboard it takes me back to the login screen. I have to close the browser to exitt.  The HTTP and the HHTPS ports numbers can not be changed from the 80 , 443 default values.  The connection is relayed even though router is UPnp enabled. But it still shows it a relayed connection after forwarding the ports. 

The UI seemed to have been designed by a High School intern and the WDSmartware doesn’t fall far behind with its poor functionality. So everything points to an incompetent software development team… (maybe this is the same one who  developed the first Healthcare.gov site?) To make matters worse, nobody from the company shows up in these forums to give any support or to try to explain what’s going on.  The www.wdc.com website has been out of service for the past couple of days. 

It’s really a shame.  A good idea, so poorly implemented.

Same problem since yesterday. The user and password I have entered are correct but I am always redirected back to the login page. What do i do?


I am also having the same issue. I can’ log onto my Dashboard and can’t access the drive remotely. This started happening yesterday.