Unable to join worldbook to active directory

I just purchase a western digital worldbook (white light NAS drive) and I keep getting this error message.

Failed to join domain! [ERROR:Join ADS failed]
 I’ve looked all over the internet I one seems to have solved this issue.  Even trying some of the things I found none of them addresses this issue.  Any help from anyone.

To resolve the domain make sure o follow this steps and it will work for you

  1.  Make sure when you nslookup the share name on the network you can resolve it

  2. Under the Domain Name FQDN of the domain e.g domain.posida.net

  3. Domain Net Bio name should remain blank " leave it alone"

  4. Domain IP you put in your AD IP address

  5. Administrator should be the domain admin for your organization. Just the name only " james"

  6. Domain password for James or the adminitrator you have added in step 5

that is it … and it worked for me let me know if it did for you too.



I tried what you suggested and still I’am receiving the same error message.  I’am about to junk this and move on.  This should not be hard to do. I’ve worked directly with our server group and had them try everything I’ve found on the web and still no luck.  I had domain admins try to get this NAS to  be added to the domain…what else can I try.  I see the NAS in active Directory because they added it…any more clues as to what’s taking place.  Thanks for all the help.

you said :

“5. Administrator should be the domain admin for your organization. Just the name only " james”"

but when i try to whrite the name of administrator, it will be stars just like i writen some password.


hi, I have the same problem with my WD1T, I searched the net but cant find any working solution and want to know if anybody did joined it to a domain?

hi .set ntp sever in date and time, your dc or main server.

say if work.thanks

Hi. I have same error. I tried all without success. I have ADS on Win2008. Did someone find a solution? Thanks.

Try this, I had WINS installed , NetBios name ( in AD users & computers top root right click /properties,Netbios name there) in caps and it worked

Hello y had the same problem but only on windws 2008 Ad in an AD 2003 its work perfectly

could this help some one

why on 2003 and not in 2008 i dont know yet


hi all

We just bought WD Word Book II and could not jion it to Domain …anyone got any new ideas so we try it on …


Did you follow the suggestions from other posters?

Follow these steps in this order:

  1. make sure the WD device is time-synched with your AD controller, best to use NTP for both server and WD

  2. use FQDN in the Domain Name field box i.e. “yourdomain.local”

  3. Leave the Domain Name NETBIOS name blank

  4. your IP address of your AD controller

  5. use a domain admin username for the Administrator field box (dont worry if you dont see the name as its normal for it to replace with asterix)

  6. Password

  7. Submit

I was having the same problem, until I disabled the NTP service in the basic setup…  Once I did that, I was able to join our domain right away…

Hope this helps.


Hi I joined my Domain sucessful (windows 2003 AD)

I can see my Useres and Groups in Folder Permissions.

I add my Users and Groups to my Privat folder.

I can Access this folder with my Windows 2003 Server.

If I try to access the folder with my Mac OS X 10.6 Client or my Windows 7 Client I get a message like Resource already in use…

Of course I want to access my Private share from different location with different users thats the idea of a NAS …

But my My Book World edition don’t let me

Hi all.

I recently bought a 4TB WD NAS and I joined the AD without problems.

The strange problem I have now is the following: with the DC and the WD NAS just setting-up as a domain member, all is working fine but, after a NAS reboot, the login script of all users doesen’t run properly.

In my login script I make a check if a user is a member of a specific group, to map proper disk: with this problem the script can only execute the lines valid for all users but not the lines with a AD group check.

In the AD I can see the WD NAS with the Netbios Name as “localhost.localdomain” and it could be the problem.

I tried to put a static entry in DNS and in WINS DB, but the problem persist.

The (crazy) solution I found is to join the doman again from the WD NAS, and the script runs without problem.

At the moment, for this problem, I can’t turn off or reboot the WD NAS.

Please, someone of you tried to reboot the WD NAS after a domain join and get this problem?


(… and sorry for my english :wink:


Most likely the clock is messed up.  I turned off ntp as suggested and set the time manually.  Even after setting the clock, the time is still wrong.  For me it kept setting off by about 2 hours.   I set the time wrong by about 2 hours and the time was then correct.   After that I was able to join the domain…

Good luck.  Let me know if this works…

I have the same problem, (windows 2008 enterprise edition)

I installed all windows updates, I update the firmware of the Mybook world.

The domain functional level is 2003 - 2008,

I installed wins,

on the WD I left the netbiosname away or filled in with caps ( I tried all possibilities)

I’m absolutely sure about the domain admin name and password

The ntp service is enabled and in the time server field I filled in the domain name of my domain, the time is now exactly the same for both systems. I also tried with manual time settings.

what can be wrong? I hope anyone has an idea.

maybe the functional level to 2000 - 2003 - 2008 ?

Mine just joined a 2008 R2 domain first go.  Functional level 2008.    Just tried against 2003, that works fine too.

If the time is more than a couple of minutes different from the domain controller it will fail because of the time limit on the security certificate required for authentication against the AD.

If you have more than one DC, make sure you put in the one which resolves against the domain name, not one of the others.

For example, if you have two DCs. and and a domain called mydomain.local

Ping mydomain.local will return one of the two IP addresses above.  In the domain controller IP field, put that address.

Hi Bodeaux182

What version of firmware are you using? 

Did you have to change any domain policies to allow the NAS to authenticate against the DC?

I’m running a Windows 2008 R2 DC in 2008 mode.  I can add the NAS to the domain and I can apply permissions to the shared folders based on AD users and groups but if I try and connect to the NAS from a Windows client or server I get an error stating ‘No process is on the other end of the pipe’.   I can map drives using the local NAS accounts no problem.

I have added a static DNS entry for the NAS drive.  I don’t have WINS installed on my domain so nothing to add there.



Hi Ben,

I have the same problem. Can’t add the NAS to the AD…

Where can I set the GPO settings to allow the NAS storage? I hope you can give me some help!

WD Error: Failed to join Domain! [ERROR: Join ADS failed]

Server: SBS 2008

WD: My Book World Edition II

Firmware: 01.01.16 with MioNet