Unable to install WD SSD Dashboard


#1

I do get following message during installation: WD SSD Dashboard has been detected on this system. Dashboard installer will uninstall WD SS version 2.0.1.0 and the installation halts.
It the first time I try to install this dashboard software. Never had it on my computer. But after installing a new SSD WD Blue PC SSD WDS500G1B0B internal M.2 drive I wanted to install the dashboard.
My OS is Windows 10 64bit.


#2

Try cleaning your system’s registry with a dedicated application in order to clear leftover or conflicting files, and then try again. If this does not work then I’d recommend contacting WD Support about this. You can send them an E-mail in the following link:

Try to provide as many details as possible related to the issue at hand alongside what you have tried so far. They may request additional information for troubleshooting purposes.


#3

I have the same issue. I cannot install it. I also contacted WD support and they told me to un install the old one an reinstall the new…Well thank you Captain Obvious! I have deleted everything I can find in the registry and nothing works. Do you have a better solution?


#4

Read the answer I got from Support:"We would like to inform that we have been using the latest version of the software on our Windows 10 without any issues and in order to understand what has been causing this on your computer, please follow the steps below:

  • Remove the software from your PC as displayed here:
    Go to your system drive(C:\ ), and go to Program Files(X86) --> WD.
    Please delete this folder and also remove the software from the Operating System.
    -Then please download it again directly from our download page here:
    WD SSD Dashboard

Should the issue persist, please provide us with screeshots of the issue occurring and any error messages you may be receiving."
Untill now, WD hasn’t answered.

I also have a problem with the Drive utilities. It doesn’t find the SDD drive.


#5

I had the same issue with the 2.0.1.0 version: I was unable to install it because of a previous version already present in my system. I fixed this problem installing an older version of the dashboard … But I’m not able to upgrade it to the 2.0.1.0 version.


#6

Does anyone have a solution to this? Anyone at WD? I cannot install any version of the Dashboard


#7

I tried the solution Francesco suggested, but no luck. I am still unable to install the WD dashboard. WD support doesn’t answer. Next time a different brand SSD for me.


#8

hi guys i got the same problem on win10 64bit
it keeps saying there an old version detected and the windows say it removing the old one to install the new one and its for 3hours now and still nothing

i never installed ssd dashboard before
i just did a clean install of windows 10 64bit
still the same problem


#9

Hi Guys,

Can you share what is the OS language that you are using when you experience this?


#10

It is in the Dutch language.

Windows 10 Home 64bit.

Motherboard is ASUS Maximus VI Formula Bios 1603

CPU is Intel I7-4770K

16Gb RAM

The WDS500G1B0B-00AS40 SSD is installed on the mini PCI-express 2.0x1 slot on mPCIe Combo II expansion card.

Sincerely

Alex

[Deleted-privacy]
Onderwerp: [WD Community] [WD SSD Products/WD SSD Drives & Software] Unable to install WD SSD Dashboard

https://avatars.discourse.org/v2/letter/c/839c29/45.png

https://community.wd.com/users/chushi_cai Chushi_Cai
March 3

Hi Guys,

Can you share what is the OS language that you are using when you experience this?


#11

Thank you!

Other users experiencing this, can you share your language as well ?


#12

English here with the exact same issue.

Windows 10 Home x64 version 1607.
ASUS G501JW ROG Notebook


#13

i just got a wd blue ssd and the latest ver of wd ssd dashboard v 2 crashes in windows 10 anavericy so had to find v1.4.4.0


#14

Thank you all for your information, I will share this with our engineering team. We will investigate and plan to improve this in the next release.


#15

Hello Guys,

I have the same problem. Unable to install WD SSD Dashboard. PC with Win 10, 64 bits, Lenovo T500. I had an Intel SSD X25-M 80GB and recently replaced it by WD SSD BLUE 250GB. Works fine as is supposed to with WIN 10 apps & old programs.

The only problem I had is when I installed WD SSD Dashboard SW. I downloaded the latest version 2.0.1.0 and then try to install it. But what was installed didn’t work, so I try to installed again and I receive the following message:

and the message stay frozen for a very long time.

Any advise of how to procede with a clean uninstallation.


#16

Hi all.

I do IT work for a living and am running into this issue about 90% of the time when installing a WD SSD Drive using the 2.* software. I never had this issue with the 1.* software nor with the SanDisk (same basic application) version. Here is what I run into:

I have uninstalled the product (this happens on computers where there has never been any WD or Sandisk Dashboard installed… ever. Deleted the WD directories, cleaned the registry, etc., etc., etc. Seems like this has been going on for for months. I am wondering why WD cannot get this fixed.

My solution to this point is to use the 1.4.4.5 version which I downloaded from Major Geeks.
(http://www.majorgeeks.com/files/details/western_digital_ssd_dashboard.html)

Hope this helps WD or someone else.


#17

Great, now your link takes us to the current worthless version 2.0.1.0 on Major Geeks. File Updated 04/01/2017 04:09 PM


#18

That stinks. If anyone else can find a link to the older version that would be helpful for all. I did check a few download sites and it now looks like they have all been updated like MajorGeeks. I would have hoped that WD would have fixed this issue by now or at least posted a solution (looks like this problem has been ongoing for over 2 months).


#19

I found version 1.4.4.5 in a network and it was difficult.
But it doesn’t work at the Windows 10 x64. I downloaded the program from the website majorgeeks.com now. But file generated date 2017-01-06. So there not the updated program lies. Support is still silent.


#20

exact same problem as everyone else in this thread
WIN10 Pro 64-bit looks like no more western digital for
me just another case of haha we got your money