Unable to install Transmission app on DL4100

Dear All 

I need help I am unable to install Transmission app on DL4100 as it say “Transmission - Failed to install App.”

Please advise I have installed plex, amule, etc but Dropbox and Transmission is not.

please advise.

Thanks in advance

Hi there and welcome to the WD community.

Does the app start to download and then when its starts installing you get the error? Try to reboot the device and then try to install the app again.

Hi ArMak

Yes its start downloading and in middle of download it say App failed to install. I have already restarted DL many times still the same problem. I am facing this issue only for Transmission and Dropbox, rest all the app i have installed. please advise.

if there a awy to install Transmission manually? 

I have downloaded GL code from WD support page and tried to build Bin package with mksap but everytime it through error that cannot excure etc. I have no knowledge of unix so this is not my area to do. What i am looking is if there is alredy bin file to download and install would be good like Plex.

please advise.