Unable to Install new update of MyCloud

After many tries I’ve managed to re-install the latest version of My cloud.
I Have Windows 10, a 64bit Laptop (LeNovo Yoga).
Used Yamicsoft Windows 10 Manager to uninstall the previous installation of ‘MY CLOUD’ and ‘BONJOUR’ (complete clean of both).
Then I went ‘manually’ to clean any “My cloud” string on the Registry (used REGEDIT.EXE) using the ‘Find’ and ‘Find Next’ feature (it found lots of lines containing “My Cloud” and “WD…” which I deleted all of them.
Rebooted under ADMINISTRATOR, and re-install the new My Cloud software.
Rebooted and logged on the my windows account and it’s working 100%

I Hope this helps some guys, like me, desperate to have it solved.

This is just an update to the Desktop App. See image below.
Click on, tap or activate image to enlarge it.

I updated both my laptop and desktop this morning without any problems. Update was downloaded to my downloads folder and then installed without any problems. I have the latest version of Windows 10, Version 1511 OS Build 10586.218.

cat0w

Hello.
I’m glad you had no problems.

Thank You.

I’ve just got back from Chicago and tried on my Home Desktop, same situation. It gives me the same error. I will have to go along the all process of deleting the Registry manually and install the new update under Administrator.

Cheers