Unable to install 3rd party apps. 8GB My Cloud Mirror Gen 1

I’ve been able to install 3rd party apps in the past though the http portal on the device. Firmware recently updated on December 21st to 2.11.157. Since then some things have been wonkey. Previously installed apps are still present on the device.

  1. When going to the apps panel I am unable to click on the add 3rd party app button. (I’ve tried Chrome, IE and Edge)
  1. Under settings Cloud Service Connection Status Failed. However, when going to network the network status shows internet access.

I’ve rebooted. Set IP from static to DHCP nothing seems to work. One warning in log
2017 Jan 11 10:18:58


Received signal 2, stopping listeners.

Here is an example. I can’t click the add 3rd party app. As it’s not selectable.

Scratch that I fixed it. Looks like a DNS issue. I updated to google DNS and everything started working. So if your facing this issue try editing the DNS servers to and your router IP.

1 Like

I’m glad you have been able to solve this, and I thank you for sharing the answer with the WD Community. This may help other Users in need.