Unable to get MyCloud to be seen as a computer

#1

My parents have migrated from OS X to windows 10 and I am trying to map their MyCloud drive so they can have their music and videos. I have tried everything under the sun to get it to display as a computer but it only shows up as a Media Device & Storage and will not display on my network when I try and map it. Any ideas? My network is set to prive at and I have tried the adapter settings trick.

#2

There are a number of things to try that are discussed in the following thread:

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

First and foremost is to ensure the Windows 10 computer has all the latest Windows 10 updates. Microsoft broke the SMB in Windows 10 last November and finally got around to issuing a fix in the March 1, 2016 update.

#3

I have tried all of those without any luck. I just updated the laptops and still nothing.

#4

You have enabled NetBIOS over TCP/IP?

If using a firewall other than the Windows embedded firewall ensure the firewall software will allow local network access.

For some simply refreshing the view in Windows File Explorer is enough to have the My Cloud show up under Network.

Ensure the My Cloud and the Windows 10 computer are using the same Workgroup name.

Try accessing the My Cloud by its IP address in the Windows File Explorer address bar.

#5

Tried all of those and I can access the cloud from IP. So I noticed the computers attached to the network will change. It will be both laptops and my cloud then I hit refresh and cloud will disappear, refresh again and one laptop will disappear. Refresh and laptop will show but not cloud, refresh again and clout will show. Could this be a router issue?

#6

Have you configured the My Cloud for a static IP address either within the router’s DHCP server administration page (the recommended way) or via the My Cloud Dashboard > Settings > Network page?

There are a number of reasons why a My Cloud may not properly display under Computer in Windows File Explorer. The various methods detailed in the previously provided link cover the main causes.

One could simply map a My Cloud drive using the IP address rather than using its My Cloud device name.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=2676

#7

Have you shut down the router, the computers, and the My Cloud and then restarted them. Restart the router first, then the computers and last the My Cloud. See if that will help.

#8

I was able to assign a static IP and solve the issue. We have a dual band router so it looked like it was hopping from band to band.

#9

So I thought I resolved the issue but it has popped up again. static IP issued and its still hopping on and off the network.