Unable to get login on cloud for new user

My MyCloud drive is set up, works as it should, has a “Connected - Port Forwarding Connection established” status for Cloud Access.  I can log in with my email/password to the WD2GO website (or using the WD2GO Android app on my phone).  I created another user (my partner), using his email address and assigned him a password.  His name, email, and folder are shown on the device, when I access the Dashboard, it shows 2 users, under Cloud Access his name/email are shown and it emailed him an access notice.  However, when he goes to log in, it says “incorrect email or password”.  I have resent the account registration email several times, I’ve waited several days, but still the online system says the email/password is incorrect.  I had to give him MY login email and password.

So how are we supposed to create another user for this thing?  I’ve tried creating additional logins for some of my other email accounts and they don’t work, either.  The only one that works is my original email account I used when setting up the machine.  What’s up with that?

Also, even though I’ve created new user accounts on the drive, even locally trying to log in will fail, saying invalid username or password.  Only my original login will work.  But when I do log in, the other accounts show up, their email, password, their folder are all present.  But the logins just aren’t there.  I’m stumped.

Nobody else has encountered this?  Creation of new users on drive seems to work, they show up on the user list, email gets sent out for cloud access.  But, neither locally nor on the cloud does the user/password work, logins fail with invalid email/password.  Only the original login/email account created during setup will work.

This makes sharing the NAS with other users impossible, both locally and over the net, which is one of the main purposes of the drive.

1 Like

No issues here.  Have you tried logging in with his account on your computer?

tnynyn wrote:

No issues here.  Have you tried logging in with his account on your computer?

Yes. No other login will work except the original that was used to initialize the drive.  I can log in using that account, create new users, enter their passwords, they receive the My Cloud email.  But, their login never works, not in the cloud, not locally.  Their folders are created on the drive, on the Dashboard it shows them as a user, everything looks as it should.  But, their login doesn’t work anywhere.  Always the same, “invalid email/password”.

I created two users with my gmail account. None mail in my inbox.

After i delete one user (not admin). For 3 hours appears in the list. After 3 hours disappear.

Slow refresh? :laughing:

With the user admin i can login anyway…


Did the user verify their account?  When you create a cloud account for a user, it sends an email to that user to verify the account and change the password.

I too am having similar problems. Have set up 3 users. all can copy to public share, but not to private shares. keep getting network passwords prompts where it doesn’t accept either WDmycloud usernames nor  Windows usernames. Says we cannot have more than drive connected? what does this mean? It is advertised as a family product but so why can we not get seperate access for each of us/ We cannot be the only people having these problems

Have gone in circles trying to map network drives etc etc. please can we have a solution?

tnynyn wrote:

Did the user verify their account?  When you create a cloud account for a user, it sends an email to that user to verify the account and change the password.

Yes, they receive the email, they click the link in the email which takes them to the My Cloud login page.  They enter the email and password and get an error stating that the email/password is invalid.   On my home network, I try to log in as the user, I get invalid username/password error.  When I log in as myself (I’m the initial user), I can see the other users that I created, their email, username, password are all set, I can resend their My Cloud invitation, but their logins never work, either locally or on the website. 

I’m not sure why I have to keep describing this over and over.  The only login for the MyCloud device that works is the one that is created when the drive is initialized.  No additional users EVER WORK, not locally, not over the web.  They receive the email invitations but that’s it, they are never able to log in because they get invalid email/password errors.

I think I discovered something by accident.  I created a new account using an alternate email address.  I received the email invitation, I clicked the link, entered the email/password I had set up.  I get the email/password invalid error.  I click the “forgot password” and have the reset email sent.  I click the reset link in the email, I’m taken to a screen where I can enter a new password.  I try passwords and get cryptic error messages about the format.  Nowhere does it say when you create the user what the format of the password must be!!!  It MUST be at least one capital letter and at least ONE number or other character.  I create a password that meets that qualification and suddenly I’m allowed access on the website.  But then I have to enter another password, which is the one I originally created for the user. 

So confusing, requiring lots of experimentation and frustration.  Is this by design?  I still don’t understand the need for entering the password twice when using the web login, either.  And now I know it can actually be two different passwords.  Such a confusing mess.

Its two separate passwords because wd2go.com accounts are universal, it just manages devices. Meaning everyone can have an account to wd2go.com.  So when a user logs into their wd2go.com, they will only see devices that is shared with them.  I can share my WD My Cloud with them and you can share yours, then they will see two separate devices that they can access.  Once they select the device that is shared with them, they can log onto that device with the user account that was created for them on the device. 

I’m experiencing the same issue.  Any resolution?

This happened to me too, the work around is to click on the “Forgot my password” link and re-create the password, I think the main account (admin) can also go ahead and reset the password within the Dashboard and then the new pass will work, though I think the user will still be asked to change it to a new one of his own though.