Unable To Format 375GB PiDrive

Hey, has anyone else here ran into an issue where you were unable to format your new PiDrive? I’ve been puzzling over this for the last 4 hours but to no avail. Some context to all of this- I purchased the 375GB version PiDrive a few weeks back, and when it arrived in the mail, I decided that before I stuff it into one of my raspberry pi projects I would like to use it as a temporary storage drive. Upon plugging it into my computer, no drive was detected. Now that’s fine, as the drive is brand new.

So, I fired up windows disk management and tried to assign it a drive letter / format it. The process of creating a new simple volume and assigning a drive letter seem to work, although it takes nearly 10 minutes to do so. The real problem comes in when that partition is sitting as a raw format, waiting to be formatted. When I try to format it, it will hang for about 5-10 minutes, then simply error out with “the format did not complete successfully” or something along the lines of “format was unable to be completed”.

I suspected something was screwy, so I went in and deleted the simple volume and created a new one, then tried to format again but the same error occurs. At this point I think something is still wrong, so I load up windows command prompt, and do a diskpart, clean command. Even after this, the same errors will occur when I actually go to format. I also tried other cables, thinking maybe it was a cable issue. I even tried other usb ports on my computer, as well as ultimately trying it on my laptop, but it’s always the same error. Now, I’m running windows 7 on the desktop, and my laptop was running windows 10.

The only thing I can image at this point is that maybe the drive has some bad sectors or something else just as horrible, so I do some scans with WD life guard diagnostic ultility, but that wasn’t helpful as it just says everything is alright. I’m totally out of ideas a this point, if anyone else has had this issue or maybe you have an idea, I’d appreciate if you throw your two cents into the mix.


Welcome to the WD Community, @kyle!

I’m truly sorry to hear about your formatting issues with the your WD PiDrive! :confused:
I suspect that there could be something physically wrong with the hard drive. However, I’d still recommend you use the WRITE ZEROS feature in the Data LifeGuard Diagnostics utility. This will allow you to completely erase the HDD and get it back to its default state. Afterwards, you should be able to Initialize the HDD and then Format it through Disk management. I hope this allows you to format the PiDrive properly.

If you still encounter the same issue after that, I’d advise you to get in touch with our Customer Support and let them know about it. You should be able to RMA it and get a replacement. For more details, check out our Warranty Policy.

Hope this helps you. Good luck! :slight_smile:

Thanks for the advice - I was able to erase it like you suggested, but the same issue keeps happening. While tinkering with it today, I tried something on a whim thinking that I’d tried everything else so why not. I created a simple volume that was just slightly smaller than the total capacity allowed by the drive, and it magically worked. I’ve scanned the drive with more than a few drive utilities and WD’s in-house program, and they all tell me the drive is healthy. I’m totally fine with a drive that has 99.9% usable space, I’d just be wondering if this is something to be concerned about? Under normal circumstances I might just return it, but I’ve got a project ready and willing to accept a new HDD and if I don’t have to bother with the shenanigans of the the returns process I’d rather not. If anyone out there with a little more technical expertise than myself had some advice, I’d be grateful.

Hi, are you using Windows Disk Management “New Simple Volume Wizard”? On the second page is lists the maximum disk space available (my 375 drive is reported as 357672 MB). Do you happen to remember what yours was listed as? Then the next page is for assigning drive letter or path and the following page is where formatting is set up. In your description above, it sounds like you selected “Do not format this drive” which would just create the volume in raw format. When I do this on my 375 drive it takes about 2 seconds. If I leave the default setting “Format this volume with the following settings:”, it formats it in NTFS with Default allocation unit size and volume label “New Volume”, with “quick format” set. This takes about 4-5 seconds on my drive. If I do a raw format first, then format with NTFS defaults, quick format, it takes 4-5 seconds. I also tried setting the “Simple volume size in MB” selection to 35763 MB (1MB greater than reported capacity) and it didn’t let me proceed to the next page. Just providing this info as a baseline for what you might expect to see (I’m running a Dell Win10 Home laptop, i7, 8GB RAM.

Yes, I am using the windows disk management ‘new simple volume wizard’. My maximum disk space reported for the drive is 357707 MB (for my 375 drive). Also, I am not selecting it to ‘do not format this drive’; not that it matters, as I’ve tried it both ways, by letting the wizard do the formatting, and trying to format it after the fact always result in the same problem. Same as you, I too left it on default settings for formatting within the wizard prompts, but the then it would just cause windows disk management to hang up. Either way I do it, if I choose my volume to be slightly under my total disk capacity, then everything will work fine, and it will create / format a new volume in the same time spans as you experience. I’m personally running Windows 7 on my desktop, and I’ve got an i7 with 12GB of RAM.

Now, I’ve been using the drive on and off for the weekend, by loading and unloading test build retro-pie image files, which are about 300GB a pop. I’ve noticed no read/write errors popping up, and I occasionally scan the drive with WDs’ drive utility. So far, everything seems fine, I figure I’ll just let it ride with my volume being 1GB under the maximum reported disk capacity.