Unable to expand - Error 2 - No such file or directory (zip)

I have waited about 3 days to finish download a pictures folder from WD My Cloud and now, once I finally got the entire folder downloaded, the system tells me:
Unable to expand “name.zip” in “folder name”. (error 2 - No such file or directory.)
What should I do as I tried to download various folders and I always get the same error message and have NO access to my pictures.
I must say that working with WD My Cloud is very frustrating :frowning:
Any help would be very welcome.
Os x El Capitan (10.11.4)

Do you have a non Macintosh computer, or one not running El Capitan you can use to try and open the “zip” compressed files? Further if using the default Apple unzip utility can you try open/extracting the zip file with a different extraction utility? That way you could isolate the problem to the zip file being corrupted or instead a (another) problem with El Capitan and the My Cloud. If you are zipping up a large amount of data/files try zipping one or two smaller files, then copy them to the My Cloud and test to see if the issue persists. Could be the problem is with a large zip file.

A quick Google search bring up numerous Mac threads over the years where people had the “error 2” issue unrelated to the My Cloud. Some indicate it may be a problem with the permissions on the zip file post copy. Others indicate it may be a problem with the Apple extraction utility. Some links:

Can’t unzip .zip files… (ERROR 2)
Error opening a zip file: No such file or directory?
.zip corrupted on Mac

Dear Bennor,

Unfortunately, I don’t have another Os but only El Capitan and no PC around.
What different extraction utility would you recommend.

I have to places where I use WD-MyCloud-bk-2 (in Bangkok) and
WD-MyCloud-IB-1(in Spain)
I am now in Spain and try to download my pictures (large format) I saved on
WD-MyCloud-bk-2 (in Bangkok) to be able to work with in Spain.
Is there a way to mirror the Bangkok Cloud to the Ibiza Cloud automatically

Indeed I am trying to download my files since a week and nothing works, I
always get errors or the download process is interrupted for I don’t know
what purpose.
The files are large. Each photo is 80Mb (RAW files) and I have a lot to

Do you know what is going wrong ?


Inline image 1]

I don’t have or use a Mac so I’m not much help in suggesting an unzipping utility. I would think any 3rd party unzipping utility would work as a test.

Do a search through this subforum for how to copy across the internet from one My Cloud to another. There are several threads that discuss that particular question and may have some possible solutions.

“The structure of the archive is damaged”
“Failed to open archive - The file is corrupted or file is unsupported”
“Error 2 - No such file or directory”

Then the problem comes from WD as they are not able to give me back my
files as they use only Zip and the zip they create is corrupted.
Sorry to say that this is not a very point for WD

What do you think ?

Does this happen to all zip files? Or only one’s over a certain size? Can you create a zip file on another computer/mobile device, preferably NOT a Macintosh/iOS device, then copy that to the My Cloud then try to unzip with the Macintosh as a test?

Does this happen to all zip files?
I have been able to open two zip files over 20 zip files, the smallest ones (4 pictures inside the folder) but I cannot open the big zip files (50 pictures inside the folder) and of course, I need to open the big folders.

I have lots of computers and mobiles but… ONLY from Apple. I have left the PC & Microsoft world and frustrations long time ago. What I see today is that WD is PC oriented and problems come with it.

I really don’t know what to do as I do need these files for my job meeting I have next week and now I am deeply in trouble.

Beside buying a new PC computer to test the zip files, do you have another recommendation or idea.

I am sorry as I am a photographer and not a computer technician and I really don’t know what to do so far beside feeling lots of frustration.
Thanks for your help

So you can open smaller sized zip files but not the larger ones it appears.

Do you have any Mac computers that are NOT running El Capitan? If so what happens if you upload a large zip file using that computer? Can the zip file be opened? What you need to do is isolate what exactly is causing the problem, is it the El Capitan OS itself? Or is there some other cause.

If El Capitan is corrupting the large zip files as its being copied there is, in all likelihood, nothing that can be done to fix the corrupted zip file. You’d probably have to use a Mac OS other than El Capitan to zip and upload the files to the My Cloud if you have to use zip files.

It is easy to blame WD’s My Cloud in this instance but there are certain issues that Apple’s El Capitan introduced that are causing problems with the interaction between El Capitan and the My Cloud. In some of those cases its the fault of the Apple OS and not necessarily the fault of the My Cloud. There is a big El Capitan thread at the following link where there is much discussion on El Capitan issues and some potential solutions or workarounds (probably not for your issue however):

Do you know which OSX I should use as I cannot test all of them to know the one works not being sure one will work any better.
To download a large file (4Gb folder) it takes about 3 days (72h) when it does not stopped in the middle of the downloading process. (fiber optical connection - download speed 300Mbps).
Meaning the WD server looks to be very slow to deliver the files as it takes 72h.
I really don’t know how to solve this problem as I am not a tecnician and don’t have this much time to test all the OS from Mac to see if one might work.
Do you have the same problems with PC & Microsoft trying to download large files > 4Gb ?

Try what ever was the prior Mac OS to El Capitan.

What is the broadband upload speed on the network the My Cloud is connected to? When it comes to remote access, where the slowest connection is, is what will limit the overall speed of transferring files to or from the My Cloud.

Because my broadband upload speed is very slow on the network the My Cloud sits on I would never attempt to remote download 4GB. Remember that there are a lot of factors that go into how fast one can transfer. Not the least of which is broadband upload speed from the My Cloud to the internet, to to the speed of the hard drive within the My Cloud. One almost never gets the advertised speed when transferring files to or from the My Cloud, locally or remotely.

Dear Bennor,
What is the main advantage of using WD-MyCloud in regards to Google Drive or Dropbox ?
Where are stored my data (within WD Data Server or in the WD-MyCloud item which stands on on my desk ?
If the WD-MyCloud is disconected from power, do I still have access to my data ?

One advantage of a local NAS (network attached storage) like the My Cloud versus Dropbox or other online storage sites is the one time only cost versus paying a monthly or yearly fee for online hosting services when storing large amounts of data beyond the small free amount they give out.

Another advantage is one isn’t having their data scanned or data mined on NAS as they would on an online storage site.

Further, another advantage is the data is stored and accessed on your local network, rather than on a remote site which may be inaccessible if your broadband connection goes down/offline.

In general, a local NAS like the My Cloud serves a different function than an online storage site like Dropbox. Far too many hear the marketing term “Cloud” with respect to the “My Cloud” and expect/assume the My Cloud NAS will operate exactly like Dropbox, Google Drive or other online storage sites.

First and foremost the My Cloud is designed for use on the local network as a central storage repository that has limited remote access capabilities using the WD software and mobile apps, and has local network basic media serving functionality.

Generally the content stored on your My Cloud unit IS NOT copied or stored on a remote storage site like Dropbox or Google Drive. If your My Cloud drive looses power then your data stored on the My Cloud becomes inaccessible/unreachable. The solution to the loosing power issue is to put the My Cloud AND the network router/gateway (and any other switches or hubs between the My Cloud and the router/gateway) on stand alone battery backup devices. There are a multitude of lower cost stand alone battery backup devices that will power the My Cloud and network router/gateway for a short amount of time (generally a couple of hours for computers, longer for lower power consumption devices like routers/gateways and NAS devices) in case of power loss.

Data is ONLY stored on your MyCloud, sitting on your desk. It is stored nowhere else, and is not available if your MyCloud is turned off. No copies are held on any WD data servers.

Back to your problem.

What created the zip files?
Can you not download the individual images without zipping?
You showed a Speedtest result, but that is almost certainly the result for where your computer is, NOT for where the MyCloud is. You need to know the uplink rate at that end, too. If both ends have 30Mbps uplink rates, then the transfer should only take about 30 minutes.

You also need to understand how you have configured your MyCloud for remote access. If you have used ‘relay mode’, then all traffic passes through WD network servers (not data servers). If you have used ‘port forwarding mode’, then the WD servers are only used to set up the transfer, after which data flows directly from your MyCloud to your remote computer via the internet, and WD servers take no further part in the transaction.

Thank you very much for all these details but I believe this is not the product that fits my needs.
Too much complicated and I honestly don’t see the advantage of using such product to save data.
Wish you good and hope so many of your your customers will sound better soon.

Neither Bennor nor I work for WD. This forum is not WD Support, and we are not WD Support staff; we are customers, just like you, trying to help fellow customers. In this case, trying to help you get access to the files you need.

If you want to contact WD for assistance, go to the WD Support page:

You may be right. It is intended for home use, not business. Frankly, if I needed to have access to images that were essential for my business, I would be using a secure commercial cloud service, or a portable hard drive. USB sticks of 128GB capacity can be bought for £10 these days; take a few, each with copies of your data, in case of loss or theft.

Maybe you need to research your purchases more carefully in future, to make sure they meet your needs.

You are 100% right with what you say and sorry for the misunderstanding about your forum versus WD Support.
I thank you for your time trying to help me and make me understand better what I had bought and realize WD MyCloud was not at all the product I needed.
I will indeed go with portable HardDrive instead.
Thank you again :pray:t2:
Best to your forum.

@cpt_paranoia @Bennor I am having the same Error 2 problem. Running Mac OS Sierra. I download the zip files and I keep getting the Error 2 “File does not exist” even though it´s 50Gb in size… Did anyone solve this problem? Please help. I have all the pictures of my 2 baby girls since born in that NAS (bought it to backup everything before doing a hard reset on my Mac). Thx!

Why are you downloading zip files?

Is your MyCloud on your local network, or are you accessing remotely?

If it is local to your network, simply map the MyCloud as a network drive (download and read the MyCloud user manual to find out how to do this) and access it with your regular file manager, just like any other disk. then you can see individual images, and copy them just like you would copy files around on your computer.

If you are trying to access remotely, go home (or to wherever your MyCloud is located), connect to the network there, and do the above.

Your pictures are probably still on the MyCloud. It’s just that the method you are using to access them is either not appropriate, or not working.