Unable to determine location, despite using Unlocator

I’ve been using Unlocator on my router for a couple of months, which allows me to use a Hulu account, even though I’m based in Dubai.
Along with everyone else on this forum, I started experiencing issues with my WDTV recently, with unresponsiveness, lock-ups, errors about low memory, and constant “hanging” of the stream in Hulu, even when set to the lowest quality.

I tried upgrading to the newest firmware, but still got the same issue, so I’ve now rolled back but every time I try to change the location/region in Settings, I get an error telling me that my WDTV is unable to determine its location.
I upgraded again to the latest firmware, but still get the same issue.

This means I no longer have the Hulu app available to use, renderning my subscription pretty much useless.

I’ve rebooted my router, removed the Unlocator DNS settings, re-entered them, tried resetting the WDTV etc., but nothing has worked.

How could this work before but not now?
Does anyone have any other ideas I can try?


Are you able to manually input a specific DNS Server configuration matching your service? Have you tried a full factory reset on your WDTV?

Hi Trancer.

Yes, I’ve tried both with no success.