Unable to delete files or folders from MyBookWorld White Light Edition


I am unable to delete files from my device. I get the following error message;

The operation can’t be completed because the item is in use.

I have tried to troubleshoot by following your Solution ID 8537 help topic ( Files cannot be renamed, deleted, or moved in a My Book World or ShareSpace when mounted in NFS on a WD TV Live Streaming)

If I drag and drop the file /folder I am trying to delete to the desktop of my MAC I am able to delete and send it to trash from my desktop, which suggests it is not a MAC issue.

Apple tech support have also tried to resolve the issue via a screen share session and have confirmed it is not a MAC issue.

The problem only happens when I try to delete a file from the WD MyBookWold NAS device.

Can anyone asadviseist please?


Do you have the same issue in all the share folders or only one file?

You can try doing a backup and performing a full factory restore. 

This will erase all data on the drive. 


Thanks for the reply. It happens in only some of the share folders, but more than just one of them